Link to home
Avatar of Axis52401
Axis52401Flag for United States of America

asked on

Cannot recieve mail after changeing Servers LAN IP address

I had to change out servers LAN IP address and now we cannot receive email. We're not receiving a connection on port 25 now. We have the Windows Firewall on the server turned off and I thought all I would have to do is change the port forwarding on the firewall/modem to forward port 25 to the new IP address. Did I miss a step?  We can send email. Our WAN IP and MX records have not changed just the Internal IP of the mail server.
Avatar of Alan Hardisty
Alan Hardisty
Flag of United Kingdom of Great Britain and Northern Ireland image

Do you have an SBS 2008 server?  If you do - have you run the 'connect to the internet' and 'fix my network' wizards?

If not part of SBS - have you checked your Receive Connectors to make sure the IP Addresses are correct in them?
Avatar of Axis52401


Yes its SBS 2008 How do I run the 'connect to the internet wizard you mentioned, The internet connection seems fine and I can send email.
In the Windows SBS Console> Network> Connectivity> Tasks Pane.

Run the 'Connect to the Internet' followed by 'Fix my Network' wizards.
Found it, it said it ran with only one error about configuring DHCP on IPV6 but I don't need IPv6 so I'm not worried about that. I don't see a 'Fix my Network' wizard. Port 25 incoming remains blocked
FOund the Fix my net wizard, running now
I get an error, Exchange SMTP connectors are Invalid

The server cannot connect to the SMTP connectors
I shouldn't have to change the Accepted domain names in this case.

I tried telnet 25 and get connection refused on the server That is the servers new IP address.

I see this entry in the Event viewer
Process MAD.EXE (PID=2668). All Domain Controller Servers in use are not responding:

Does something in Active directory have to be changed as well. I've changed the IP address on Servers running Exchange 2003 before and not had this problem.
What are the IP Address settings on your server and what have you got DNS pointing to on the server's NIC?
Windows IP Configuration

    Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom BCM5716C NetXtreme II GigE (NDIS VBD Client)
   Physical Address. . . . . . . . . : 78-2B-CB-12-A1-F1
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled
Now the Information Sotre service wont start

Unable to initialize the Microsoft Exchange Information Store service.   - Error 0x96e.
Have you rebooted since changing the IP Address?  If not - now would be a good time me thinks.
Rebooting now
The server rebooted and no longer shows, port 25 being blocked, and the Info store svc is running but we're still not receiving email. That error is gone as well
Okay - please re-run the fix my network wizard.
Avatar of Praveen Balan
Praveen Balan
Flag of India image

Blurred text
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Where would I find the internet receive connector settings. I see a recieve connector in Exchange but no 'Use these local IP... setting
Also I can now successfully telnet to port 25 on the server and from the local PC's but not from externally
  I get Windows SBS 2008  fix my network wizard has stopped working. A problem caused the program to stop working correctly. Windows will clsoe the program and notify you if a solution is available.
On recieve connector properties,
Go to Network Tab and see the local address and port 25. By default it will be use all local IP address available on server. In case it has changed and used any IP specifically update it with the newly given IP.

View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
Thanks guys, that was it, thanks for all of your help.