Cannot recieve mail after changeing Servers LAN IP address

Axis52401
Axis52401 used Ask the Experts™
on
I had to change out servers LAN IP address and now we cannot receive email. We're not receiving a connection on port 25 now. We have the Windows Firewall on the server turned off and I thought all I would have to do is change the port forwarding on the firewall/modem to forward port 25 to the new IP address. Did I miss a step?  We can send email. Our WAN IP and MX records have not changed just the Internal IP of the mail server.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Do you have an SBS 2008 server?  If you do - have you run the 'connect to the internet' and 'fix my network' wizards?

If not part of SBS - have you checked your Receive Connectors to make sure the IP Addresses are correct in them?
Axis52401Security Analyst

Author

Commented:
Yes its SBS 2008 How do I run the 'connect to the internet wizard you mentioned, The internet connection seems fine and I can send email.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
In the Windows SBS Console> Network> Connectivity> Tasks Pane.

Run the 'Connect to the Internet' followed by 'Fix my Network' wizards.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Axis52401Security Analyst

Author

Commented:
Found it, it said it ran with only one error about configuring DHCP on IPV6 but I don't need IPv6 so I'm not worried about that. I don't see a 'Fix my Network' wizard. Port 25 incoming remains blocked
Axis52401Security Analyst

Author

Commented:
FOund the Fix my net wizard, running now
Axis52401Security Analyst

Author

Commented:
I get an error, Exchange SMTP connectors are Invalid

The server cannot connect to the SMTP connectors
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Axis52401Security Analyst

Author

Commented:
I shouldn't have to change the Accepted domain names in this case.

I tried telnet 192.168.10.6 25 and get connection refused on the server That is the servers new IP address.

I see this entry in the Event viewer
Process MAD.EXE (PID=2668). All Domain Controller Servers in use are not responding:
SBS01.company.com.local

Does something in Active directory have to be changed as well. I've changed the IP address on Servers running Exchange 2003 before and not had this problem.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
What are the IP Address settings on your server and what have you got DNS pointing to on the server's NIC?
Axis52401Security Analyst

Author

Commented:
Windows IP Configuration

    Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom BCM5716C NetXtreme II GigE (NDIS VBD Client)
   Physical Address. . . . . . . . . : 78-2B-CB-12-A1-F1
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.10.6(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.10.1
   DNS Servers . . . . . . . . . . . : 192.168.10.6
   NetBIOS over Tcpip. . . . . . . . : Enabled
Axis52401Security Analyst

Author

Commented:
Now the Information Sotre service wont start

Unable to initialize the Microsoft Exchange Information Store service.   - Error 0x96e.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Have you rebooted since changing the IP Address?  If not - now would be a good time me thinks.
Axis52401Security Analyst

Author

Commented:
Rebooting now
Axis52401Security Analyst

Author

Commented:
The server rebooted and no longer shows, port 25 being blocked, and the Info store svc is running but we're still not receiving email. That error is gone as well
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Okay - please re-run the fix my network wizard.
Praveen BalanSolution Architect
Commented:
Just an out of box thought,
could you check the internet receive connector properties and ensure that Use these local IP to receive is updated with the new IP Address of the Server?

If the IP shows the old one, that could be causing for you to not receiving email...
Axis52401Security Analyst

Author

Commented:
Where would I find the internet receive connector settings. I see a recieve connector in Exchange but no 'Use these local IP... setting
Axis52401Security Analyst

Author

Commented:
Also I can now successfully telnet to port 25 on the server and from the local PC's but not from externally
Axis52401Security Analyst

Author

Commented:
Alan,
  I get Windows SBS 2008  fix my network wizard has stopped working. A problem caused the program to stop working correctly. Windows will clsoe the program and notify you if a solution is available.
Praveen BalanSolution Architect

Commented:
On recieve connector properties,
Go to Network Tab and see the local address and port 25. By default it will be use all local IP address available on server. In case it has changed and used any IP specifically update it with the newly given IP.

-Praveen
Co-Owner
Top Expert 2011
Commented:
In the Exchange Management Console under Server Configuration> Hub Transport> you should see the Receive Connectors.

Check the server IP settings in the connectors listed and amend accordingly.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Have you changed your internal DNS records too:

http://blog.mpecsinc.ca/2009/03/sbs-2008-how-to-change-servers-ip.html
Axis52401Security Analyst

Author

Commented:
Thanks guys, that was it, thanks for all of your help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial