We help IT Professionals succeed at work.

Outlook Anywhere - SBS 2011

compsol1993
compsol1993 used Ask the Experts™
on
Hello,

We have a SBS 2011 server, and Outlook anywhere is turned on.  We cannot get our Outlook clients to connect.  I used the Microsoft REmote Connectivity Analyzer, and everything passes until this step:

Attempting to ping RPC endpoint 6001 (Exchange Information Store) on server mail.********.com.
       The attempt to ping the endpoint failed.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process.

Any suggestions on what we need to do to get this work.  This is stock SBS 2011 install,
nothing has been modified.  Exchange itself, along with OWA, Activesync, works fine.

Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2010

Commented:
We cannot get our Outlook clients to connect.
>> Are these outlook clients connecting locally or remotely.

did you configure the exchange server or you are still setting it up ?
Was it working earlier ?

Author

Commented:
Sorry, should have made that clearer:

Local clients are fine, it's the remote clients that cannot connect.  (These clients have never connected, so we cannot get them setup initially).

This server has been in production about 1 month.  Internally, everything is fine.  We now need to setup a remote PC, and cannot.  We used the Microsoft Remote Connectivity Analyzer, and found the error there, as Outlook wasn't telling us specifically what was wrong.

Thanks
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
- Browse url https://mail.yourdaomin.com/rpc/rpcproxy.dll extenally post what you are getting.

- Browse url https://localhost/rpc/rpcproxy.dll locally and post what you get.

Author

Commented:
In each case, I am prompted for a username and password.  Once I enter the username and password, the login box disappears and I am presented with a white page.  It appears to have accepted my login.  What does this mean?

Thanks
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
- It proves that rpcporxy.dll is getting authenticated properly.

- Make the following changes in the system32\drivers\etc\hosts file:

Comment out the line ":::1    localhost"

Add the following two lines:

   <IPv4 address>    <hostname of the computer>

   <IPv4 address>    <FQDN of the computer>

- Go to command prompt run below commands:
ipconfig /flushdns
ipconfig /registerdns

- then IISReset to restart IIS.

- Above changes perfom testexchangeconnectivty test.

Author

Commented:
Thanks for the info, I tried exactly as you described and still the exact same error.  The only thing I could not do is comment out the line, as it was already commented out.  I do not believe anyone commented this out before now, as I have not, and the server is a fresh install.  None the less, adding those lines did not make any difference.
Technical Manager
Top Expert 2010
Commented:
- Check HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

Make sure NSPI interface protocol sequences present and in the Value data box, ncacn_http:6004 is there.

- Please make sure “ValidPorts” at HKLM\Software\Microsoft\RPC\RPCProxy contains
servername:6001-6002;severname.domain.local:6001-6002;mail.domain.com:6001-6002;severname:6004;severname.domain.local:6004;mail.domain.com:6004

Note: Modify above vaules to match your local and external domain names.

- Make below change. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeServiceHost\RpcHttpConfigurator\PeriodicPollingMinutes regkey. Note that setting this value to 0 turns off the RpcHttpConfigurator

- Reboot the server once and test.

Commented:
What shreedhar suggested is excellent !
I would just add the following, if the above steps does not help
Run in CMD
>nestat -anob
check proceess (PID) that are using ports 6001, 6002 and 6004

Also reinstalling the RPC over HTTP component of IIS might help.
Before reinstalling disable Ooutlook Anywhere from EMC , then enable it again

Author

Commented:
Thanks for the help.