Remote Exchange Connection not working

posae
posae used Ask the Experts™
on
Hello,

We have a SBS 2003 environment that uses Exchange 2003 (6.5.7638).  We have some users that have laptops that access Exchange using Outlook 2010 over the internet.  This has been working fine for a long time, however, I am trying to set up two new laptops (one replacement and one a new user) and I cannot get their Outlook installation to sync with Exchange.

I continue to get the following error message when I put in the server and username:
Microsoft Outlook
The action cannot be completed.  The connection to Microsoft Exchange is unavailable.  Outlook must be online or connected to complete this action.

This is the initial setup of the mailbox so I do not know how to turn it online.  Also, I am using the same config for another user and it is working fine.  

I have gone into the "More Settings" Tab and set the exchange proxy settings to the same as the working user but no avail.

any thoughts?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Adam BrownSenior Systems Admin
Top Expert 2010

Commented:
Check the Encryption settings of the working Outlook 2010 clients. Outlook 2010 sets a requirement for encryption between the client and exchange by default. If your Exchange server isn't set up for encryption, that can cause connectivity issues. The settings are on the Security tab of the More Settings window.

Author

Commented:
No luck...I inherited this server and I am wondering where I go to look the exchange settings for these remote connections
Top Expert 2010

Commented:
a) can you ping the exchange server by name from the laptop ?
b) Are you connected using Wireless or Ethernet ? If Wireless - is it on the same subnet, or a different subnet.

If above, is true, then go here
c:\windows\system32\drivers\etc

Right click the file "hosts" and open with notepad

enter the name and IP address of Exchange Server in the end

For example

192.168.1.10 myExchangeServername

click Close and save the file
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
This is a remote user that is not on the same network.

Author

Commented:
I am trying to get them to access via HTTP and tested out using https://www.testexchangeconnectivity.com.  it fails because of a certificate error.  it is self assigned and the other laptop is using it.
hecgomrecNetwork Administrator

Commented:
Hi Posae!

Here is 3 things to consider before you loose your head about this (as I did).

1.- Check if the computer has access to the internet.
2.- Is this a clean install or from an existing installation.
3.- Was the computer recently affected by a virus or something change on it.

If you check number 1 and is ok then must you have one of the 2 other scenarios.

My recommendation is  to do a repair installation from your CD/DVD of "Windows" don't touch your server or your office installation.  This happend to me with winXP so I'm guessing you are in the same situation. You can ping the server, you can browse your internet but for some reason you can establish connection with your email server.  I had that experience with 2 computers did the repair and solved.  Unless you have time for find another solutions this is my recommendation by experience

Author

Commented:
This is a fresh installation and it is happening on multiple machines.  Even happens if i bring the laptop internally to the network and do this.  

One question...we recently changed our office IP address.  We changed the DNS entries for webmail.broadelmmanagement.com to point to the new ip, however, I am wondering if there is another change that needs to be made for the autodiscover functionality.  

The smartphones are working and existing laptops are working, it is just the setup of new devices.
hecgomrecNetwork Administrator

Commented:
Thanks for submitting your real address.

Now I know what is the situation.  the address provided does not point to your "mail" or  OWA server.  This points to your Remote Web Workplace "RWW".

For your emails to work you need to point to http://webmail.broadelmmanagement.com/exchange  and the DNS will do the rest.

Note: You should fix your DNS records with your IP provider to properly display services in your servers.  webmail.yourcompany.com (OWA) and remote.yourcompany.com (RWW) even if they point to the same server (IP) as each will be redirected on your firewall to the right service and port.

Hope this give you some light

Author

Commented:
Thanks hecgomrec!  I think we are on to something.  Couple things to consider:

1.  Existing laptops are working with these settings, just trying to configure a new setup is the problem.

2.  They used to be broadelmmanagement.com but changed to tmmontante.com.  The certificate for the site is webmail.broadelmmanagement.com so we point that to the new IP address of their facility

3.  Phones are currently working AND i can configure new ones with the following settings:
      a. Domain:  bemgmt.local
      b. Webmail.broadelmmanagement.com
      c. Requires SSL
hecgomrecNetwork Administrator

Commented:
Are this phones working inside and outside the company?

As I stated before, if you go and type "webmail.broadelmmanagement.com" using or not SSL I get to the same place... your RWW.  Remember, this is from outside your company as I am right now.

If you have the same name inside your network, your local DNS might be the issue as internally it can be pointing to the right service service but outside your LAN no one can access your Mail (OWA) with those settings unless you use "webmail.broadelmmanagement.com/exchange". Try to check emails with a working device using an internet signal outside from your company and let me know.

Author

Commented:
The phones are outside the company.   Internally there is a DNS entry that points webmail.broadelmmanagement.com to the local BEM-MAIN server which is the exchange server.  

I am wondering if there is something on the server that is not listening properly?  The laptops that are working are outside the office.
hecgomrecNetwork Administrator

Commented:
Wow I'm surprise!

I can't get access to your OWA with that address. So I guess you have your POP and SMTP pointing to the same NAME.

Now I'm confused, If you have devices configured in 1 way before your changes how they communicate to your server after those changes, unless you change them manually.

Could be that you just not using the right ports on your configurations settings, please check

Author

Commented:
Thanks hecgomrec.  When you say ports on my config, where are we talking.  I am assuming on the server?  If so, where are these set?  I did not set this up originally and am not sure as to where these settings are.  

The thing that gets me the most about this is that it works for existing remote users using outlook.  There has to be something during the process of config that outlook is trying to do that cannot accomplish.
hecgomrecNetwork Administrator

Commented:
Ok I will try to help you as much as my expertise allow me to but you need to clear out something:  You want to install computers and/or phones for new users?, what is the OS for the new computers?, Does the users have the correct rights to use ActiveSync and Mail?, Have you open your internet browser and try to connect to the server using https://webmail.broadelmmanagement.com/exchange


Forget about the ports, if you have PCs working the ports should be fine.

In the affected computers please open a CMD windows with Administrator rights and run " Ping <your internal server name>, then run it again with your DNS name " webmail.broadelmmanagement.com  " both IP numbers whould be the same.

Let me know all this

Author

Commented:
Thanks:  In the first post I mentioned that this is a replacement laptop for one that went down.  This user was originially set up to work with Outlook 2010 and connect to mail over HTTP.  Harddrive died and it was replaced with same OS, username, PWD, etc.  Right now the user is using OWA to access mail by going to webmail.broadelmmanagement.com/exchange

This is a remote user so when they ping this web address, it resolves to the external IP of the office correctly.
hecgomrecNetwork Administrator

Commented:
How are you connecting to the server, POP, MAIL, etc....


Do you mind to sent me the settings you are using to connect this user to your server?

If you don't want to post them here use my email hecgomrec@rd-international.ca

I will try to replicate the settings and give you the feedback, you can change user's password afterward or if you have a testing account even better.
Commented:
I have found the resolution.  The issue was that I had to install the certificate in the Trusted Root Cert Authority.  I had not installed it in this place but another.  Once I did this, the account worked like a dream.

Author

Commented:
found my own answer

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial