Link to home
Start Free TrialLog in
Avatar of ohface
ohface

asked on

Remote Desktop not printing

Good morning Experts.

I have Windows Server 2008 R2 running remote desktop services and I'm unable to get the redirected printers working. Once connected, the redirected printers show up in Devices and Printers and appear to be fine. If I print a document, it shows in the print queue and then disappears as if it printed normally. After a few minutes, sometimes the printer icon becomes subdued and states "disconnected". If I log off the session, and then reconnect, the printer appears connected again, but still does not print.

Both clients this has been tested with were Windows 7 Pro 64-bit, one has a Dell 1320c and the other is using and HP Laserjet M175nw. I've enabled "Use Remote Desktop Easy Print printer driver first" and verified the print spooler service is running.

Thanks in advance for the help.
Avatar of IT_Crowd
IT_Crowd
Flag of Heard Island and McDonald Islands image

We've had something similar in our environment. In the end, we needed to install the same drivers that the client was bringing into the RDP session.

Let me know if that doesnt fix the problem.

-IT_Crowd
Avatar of ohface
ohface

ASKER

@IT_Crowd Thanks for the response.

I've installed the 1320 driver on the server (standard add printer wizard), logged off and back on, and still unable to print from the redirected 1320, and I can't find a place to update the driver for the redirected printer. Is there a certain why I'm to install the driver for this?
It might work from there, I normally go through Start -> (search for Print Management)

Under Print Servers, select your print server, and then Drivers. I add the driver at that location.

-IT_Crowd
ASKER CERTIFIED SOLUTION
Avatar of Spike99
Spike99
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of ohface

ASKER

@IT-Crowd - I didn't have the Print and Document Services role installed, so I added that and followed your advice with the drivers. Still unable to print. Wasn't sure if the Easy Print was causing the system to ignore the drivers, so I disabled that and still no go.

@Alicia - Thanks for the response. I'm testing it as an admin so I don't think it is a permissions issue. If I get it working as admin, but the users still can't print, I'll try your suggestion.
Avatar of ohface

ASKER

@Alicia - Yep, you were correct. Not sure why the admin account couldn't print without the Everyone group having full access, but it worked.

Thanks a lot for the help!
No problem! I'm always happy to help out.

For whatever reason, to get full access to all printing features, having admin rights isn't enough with 2008.  You have to be a member of the print operators group. I don't understand why MS did it that way.

BTW, thanks for the points!  That put me over the top to "Master" status for printers & 2008.

:)

Alicia