Avatar of CptnTrips
CptnTrips
 asked on

Running virtual machines without VMTools

I have a server that is having unusal memory problems. It appeared that the applicaiton had a memory leak. We went back and forth with the vendor, literally for months trying to rememdy the problem.

It is a Windows 2008 R2 virtual server running on ESX 4.1. RamMap showed 9 to 10GB of data being use by "Driver Locked" as stated in this case:
https://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_26259037.html
As stated in this case as well, killing VMtools sees to have resolved my memory issue.

So my question is this; considering I have no problems from any other Windows 2008 R2 server I have in this cluster like this, I am reluctant to turn off VMtools. I am by no means a VM expert and am unsure what the consequences are other than jerkly mouse in the conolse, inability to drag and drop files from my desktop to the console and one or two other things.

Is there any significant downside to removing VMtools from a VM for an extended period of time? Am I going to get bitten in the ass weeks, months from now because I don't have VMtools loaded?
Windows Server 2008VMware

Avatar of undefined
Last Comment
CptnTrips

8/22/2022 - Mon
Neil Russell

If you edit the VM Configuration, on the resources tab, is the Memory limit set? If so set it unlimeted and try again.  You do not need to stop the VM or reboot.
ASKER CERTIFIED SOLUTION
Neil Russell

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Chris

If you turn off VMtools you lose the interaction to the host.
you won't be able to use the vmnet3 NIC's which means you loose performance there

I think most of the HA/DRS feature will not work because the rely on the heartbeat from the tools
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

It is recommended and best practice to install and use VMware Tools in the Virtual Machine.

However if its causing service issues, dump vmware tools, and remove.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Neil Russell

VMWare tools is not the issue, it is configuration. The loss of VMWare Tools is a no brainer, dont do it.
CptnTrips

ASKER
Neilsr-

I have 16GB of memory assigned to this VM. If I create a resource group with 16GB of memory set as a minimum, expandable and no limits, I see the runaway memory. Is this what you are suggesting to solve the memory issue?
Neil Russell

No I have not said to set any minimum, just tick the no limit box.
Not a seperate resource group, I am on about the resource tab on the VM Configuration when you edit the VM.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
CptnTrips

ASKER
What if I remove VMtools and simply reinstall without the memory management?
CptnTrips

ASKER
Neilsr, I'm with you now. I will investigate that as well. Thanks.
CptnTrips

ASKER
I do see that processors were set to unlimited but memory was not. Let see how this change does. Thanks again and I will update you when I have some new information.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Neil Russell

Why do that? You just need to edit the VM Settings and tick one box.....
CptnTrips

ASKER
I have edited the VM settings and ticked the Unlimited option of the memory tab. This will be the only change I am testing.
Chris

one question - if its a memory leak then giving it unlimted memory will just use up more on your host

have you checked the version of the VMtools as it shows in the post you linked to
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Neil Russell

Yes

Now give the VM a few minutes to stablise.

We had this issue on several fileservers where the allocated memory was greater that the Resource Limit on the VM, made the FS as slow as hell due to the ballooning.

Tick the Unlimited box and 5 mins later.... VIOLA!!!
CptnTrips

ASKER
Awesome. I will let you know the results. Thanks!
Neil Russell

*Crosses fingers now* Sounds exactly like the same problem......
Your help has saved me hundreds of hours of internet surfing.
fblack61
Robin CM

Use the following Powershell (via PowerCLI) to show any VMs that have memory limits set:
Get-Cluster YourClusterName | Get-VM | Get-VMResourceConfiguration | where {$_.MemLimitMB -ne "-1"}
CptnTrips

ASKER
Neilsr - so far so good. I actually scalled the memory back from 16GB to 8GB and processors from 4 to 2 and I am seeing very positive results. Not sure why this is not a problem for all of my other 2008 R2 serves though?

robincm - thanks! I have been checking them and so far, there only seems to be a small number with a limit set. I am still wondering why I haven't seen this problem with them as well though. The best I can come up with, these being set may be the result of the 4.0 to 4.1 upgrade? Not sure why they are different than all of the others but this seems to be working so far.

On my way out the door, I will update you in the morning. Thanks again!
CptnTrips

ASKER
One additional note, I may be imagining this but the CPU usage is down to pratically 0% now as well... Would CPU usage have been affected much by the this issue?
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Neil Russell

Yep it makes a MASSIVE impact on machines. never been given an explination from VMWare that tells me anything though.
Neil Russell

As to why the impact is only showing on this one machine. I have found that the impact is only felt when the allocated memory is in excess of the resource limit by a fair amount.

If your resource Limit was ~= to your allocated then no impact.
If your Resoucre Limit << your Allocated Memory then.... OOPS!
Neil Russell

Do you have an update? Has that solved your problem?
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
CptnTrips

ASKER
Sorry for the delay. I saw postive results until this morning. I am back to 0 free memory again. However, this time when I run RAMMap, "Driver Locked" is using nothing where it was using GB's before. So I seem to have had a positive impact in the sense that I see no ballooning or anything that indicates anything going on with memory in the VMware side of things. But I am back to 0 free memory again as of this morning...
Neil Russell

So the solution to the question you asked is correct.

Now the fact that your server is using all available memory to it is a different matter.

The ballooning and Driver Locked issue is resolved.

If you run your server but NOT the application I assume you have no memory problems?


You should be talking to your application people again I think on that matter.
Robin CM

Bear in mind that some applications (e.g. SQL Server) will by default gradually consume all the RAM in the server (you can configure a maximum limit). In the case of SQL Server this is because the designers know that keeping as much data in RAM as possible is a good thing as RAM is significantly faster than disk.
Of course it could just be a memory leak :-)
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
CptnTrips

ASKER
I do beleive the problem to be related to the application or possibly a known issue with Windows and cached memory. Either way, I no longer beleive it to be VMware related. I am leaning towards this right now as the tests specified are getting me results that indicate this is a problem.
http://support.microsoft.com/kb/976618

Thanks for your help.