Avatar of Tim
Tim
Flag for United States of America asked on

Exchange 2003, Outlook Web Access

I have just rebuilt my OWA server and have re-added SSL certificate to the server. I can access the site but when I put my domain\user name and password into the login screen I get  "You could not be logged on to Outlook Web Access. Make sure your domain\user name and passwords are correct, and then try again. "

What am I missing? I can get messages to my Outlook but cannot login to OWA or and Mobile devices. Where do I need to go to start troubleshooting this issue?
ExchangeMicrosoft ApplicationsWindows Server 2003

Avatar of undefined
Last Comment
Tim

8/22/2022 - Mon
Shreedhar Ette

- Rebuilt my OWA Server means it is Front End server?
Tim

ASKER
When I mean rebuilt I meant recreated the Virtual directories. I really didn't do a complete rebuild of the system.
Tim

ASKER
I followed a knowledge base on MSExchange.org "Fixing a damaged or incorrectly configured OWA 2003 Installation". I'm sure I missed a step or a step was not included when following this KB.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Shreedhar Ette

- Does all the virtual directory created after following MSEXchange.org article?

-  Have set the permisson as per the article:
We need to reset the access permissions to Anonymous on the ExchWeb virtual directory. In order to do so start the IIS Manager then right-click the ExchWeb virtual directory and select Properties. Now select the Directory Security tab and click Edit under Authentication and access control. Make sure the Anonymous access and Integrated Windows Authentication check boxes are enabled then click OK and Apply. If an Inheritance Overrides dialog box pops up make sure you click Select All then OK. Under Authentication and access control, click Edit then clear the Integrated Windows authentication check box again. Click OK twice and you’re done.
Tim

ASKER
OK, I did what you said and we are half way there. I am able to access the OWA which is pleasing however when I try to access\create an account on my mobile device it tells me "Failed to create the account. Please try again later." I'm sure this is a setting in OMA but I really don't know can you help me with this last thing?
Shreedhar Ette

- Are you configuring mobile device for activesync access?

- Certificate installed on IIS is a self sighed or 3rd party?

- Does there is any error event in application log related to activesync?
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Tim

ASKER
I think I found the problem. This is what I found in the events.


Event Type:      Error
Event Source:      Server ActiveSync
Event Category:      None
Event ID:      3029
Date:            5/21/2012
Time:            3:54:13 PM
User:            Domain\User Name
Computer:      Exchange
Description:
The mailbox server [Exchange.Doamin.com] has its [exchange] virtual directory set to require SSL.  Exchange ActiveSync cannot access the server if SSL is set to be required.  For information about how to correctly configure Exchange virtual directory settings, see Microsoft Knowledge Base article 817379, "Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817379).

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

In answer to your questions: Yes I am configuring my Mobile device for activesync. Yes I have a Certificate installed on the exchange from a 3rd party (GoDaddy).
ASKER CERTIFIED SOLUTION
Shreedhar Ette

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Tim

ASKER
I don't like that solution since I never had a secondary virtual directory before I had these issues.

So I tried the solution and when I go to run IISRESET/NOFORCE I get an error message.

Restart attempt failed.
The service cannot accept control messages at this time. (2147943461, 80070425)
Shreedhar Ette

just execute iisreset

check activesync
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Tim

ASKER
I tried this solution and followed it to the T and still my device will not create an account. Do i need for this to propagate?
Shreedhar Ette

Check application event log for warnings and errors.
Tim

ASKER
I have looked and nothing is posted. Each time I go through configuring my Android device it goes through like my user name and password is correct however when I go to finish the configuration it tells me that is failed to create account. Is that on the phone or on the server? Can it be that I need to delete an old account that was used to synchronize to my phone? This is killing me!
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Tim

ASKER
I finally fixed this issue. The problem was when I copied the Exchange virtual directory and created the second virtual directory that was supposed to have SSL turn off on forms it did not. I found this out by using the following site https://www.testexchangeconnectivity.com/ which was quite helpful since the logs on the server were not reflecting the failed connections by my phone.

Thanks for all your responses and help on this issue.
Tim

ASKER
This helped my down the path but didn't completely fix the problem.