Slow opening documents in SharePoint Foundation using Windows 7 and Office 2007/10

bilbazafa
bilbazafa used Ask the Experts™
on
I have Windows 2008 R2 SP1 with all updates, and SharePoint Foundation installed using the local version of SQL that is bundled with the software.

The problem I have is when opening Office 2007/10 documents using Windows 7 32Bit through SharePoint; it takes about 2 minutes to open them?? If I use Windows 7 and any other version of Office its fine, documents open in seconds. If I use Windows XP and any version of Office (including 2007/10) it is also fine. It is only Office documents, PDF’s open fine.

Everybody on the Internet say to switch off checkbox automatically detect setting in IE8 / Tools / Internet Options / Connections / LAN settings / Automatic configuration. But this does not fix the problem for me, plus I don’t think its and IE problem as it’s the same when using Firefox.

I’m stuck with this one. Many thanks in advance for your help.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Hello. That is the usually solution for your problem but if you say that it doesn't work i will try to figure out what's wrong.

Check this http://support.microsoft.com/kb/2619824

I will look more and let you know if i find anything. Keep me posted with your progress.

Good luck!
Sorted it, I just created and alternate access mapping, other than using the http:\\servername and all is well.

Regards

Author

Commented:
Simple but weird solution!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial