Adobe Reader 9 - "Access Denied" Attachment error in outlook

gfsupport
gfsupport used Ask the Experts™
on
Hello fellow Experts,

Im having a problem within outlook 2010, the problem is when trying to open PDF documents that are attachments.

When I try opening the attachment I get an error as such "Access Denied"

The funny thing is when I drag the attachment to the desktop im able to open the attachment.

The version of Adobe reader is 9 I can’t upgrade as I have custom software that is not supported but Adobe Reader x

The environment is a Terminal Server setup.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
TechnoChatWintel Administrator / Cloud Computing

Commented:
Problem with outlook temp folder, go to following location on registry and change the folder.
[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Security]
"OutlookSecureTempFolder"="Change the Default folder here"

Open in new window


Default folder looks like following:
C:\\Users\\username\\AppData\\Local\\Microsoft\\Windows\\Temporary Internet Files\\Content.Outlook\\7M4QI84X\\

Author

Commented:
Thanks for you possible solution, where do you want me to change the folder too?
TechnoChatWintel Administrator / Cloud Computing

Commented:
Yes, create a folder on that location, check the permission and update the same on registry.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Top Expert 2012

Commented:
Try uninstall adobe Reader 9 and re-installing it

Id also check that SP1 is installed
http://support.microsoft.com/kb/2460049

there were a few known issues with PDFs

And lastly, check to see if cached exchange mode is on
If it is try turning it off

Author

Commented:
@ apache09

Thanks for you comment.

I have tried reinstalling but this did not work. Its a terminal server environment so cached mode is off in outllook.

All updates are installed.

@ TechnoChat

Just waiting for confirmation on your fix
TechnoChatWintel Administrator / Cloud Computing

Commented:
Have you created a new folder and updated on the registry?

Is the problem still there?

Author

Commented:
Morning,

The problem I found with updating the registry is that I would have to do this for every single user on the Terminal server as they pointing to a different folder location for each user.

I changed this location for my account on the server and it still happens.

This now also happens to Word documents.
TechnoChatWintel Administrator / Cloud Computing

Commented:
Ok,
Do this..
- Create a folder C:\SHAREDTEMPFOLDER
- Give Everyone/Authenticated Users Full Permission on that folder.
- Modify the default users registry settings, which will be applied for all users on next logon.
 
[HKEY_USERS\.DEFAULT\Software\Microsoft\Office\14.0\Outlook\Security]
"OutlookSecureTempFolder"="C:\\SHAREDTEMPFODER\\"

Open in new window


Do a test on above settings, hope this will do the job.

NOTE : Above registry value might not be there, you have to manually create that or download the attached txt file, rename it to .reg and import to the server.

OUT-R.txt

Thanks
Saugata
TechnoChatWintel Administrator / Cloud Computing

Commented:
I have created a policy file for you, you can use this policy file to apply the settings from group policy.

Download:
https://www.dropbox.com/s/jovnusg7212lmpx/OutlookTemp.adm

Author

Commented:
Thanks for you solution but this has not worked.
TechnoChatWintel Administrator / Cloud Computing

Commented:
What eror message your are getting now, after changing the temp folder?
Did you tried with policy?
If you manually change the folder on single user, problem getting resolved?

Author

Commented:
I set this in GPO The error when opening attachements is "access denied"
Top Expert 2012
Commented:
Can you close and open outlook using

Start>Run>Outlook.exe /safe

Then try opening one......

If you can open it in safe mode, likely there is an add in causing this behavior

Author

Commented:
Question not answered but need to close, thanks for everyone's input

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial