Avatar of itbabe
itbabe
 asked on

I want to remote control my imac from a windows 7 64 bit machine

I installed tightvnc viewer on the windows 7 64 machine and enable screen sharing on the imac.

When I try to connect to the server via the interface as in the attached screenshot called servername.jpg  (where the word servername is replaced by an ip adres of course), I get the error message as in the attached screenshot named error.jpg

Which port should I connect to ?
What is the format to be used ?  servername:port ?

Best regards,
Annelies
sernername.png
error.png
Mac OS XApple NetworkingRemote Access

Avatar of undefined
Last Comment
maximus5328

8/22/2022 - Mon
DVation191

First, if these machines happen to be right next to each other, you should try synergy:
http://lifehacker.com/254648/how-to-control-multiple-computers-with-a-single-keyboard-and-mouse

As for the VNC connection, try setting the vnc client to Max/Full color and try connecting again.

More info: http://www.realvnc.com/company/press/news/lion-information.html
PaulNSW

Assuming they are both on the same network, it should work ok without needing a port, unless you've specified an alternative port on the iMac.

Check that a user had permissions enabled for screen sharing on the Mac and also the firewall on the Mac configured to allow screen sharing.

If that fails, try another VNC client or LogMeIn/TeamViewer
maximus5328

Click on Options and specify port 5900 there.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Eoin OSullivan

The VNC Service on OSX is locked on the default port of 5900 and cannot be edited in the OSX Sharing : Preference Pane

Is VNC enabled on OSX and there is no firewall blocking traffic on port 5900?
http://www.dssw.co.uk/blog/2011/08/03/setting-up-the-vnc-server-in-mac-os-x-10-7-aka-lion/
itbabe

ASKER
@ maximus5328

Where should I configure this port configuration.
Find attached a screenshot of what I see when I click on options when clicking on "options" in the vnc client.
serialband

I see no screen shot.  I believe maximus5328 means on the VNC client, but tightVNC doesn't have that option.  You should also be able to enter it in the server name field with a colon separating the name such as server_name:5900  Since 5900 is the default VNC port, it will revert to just server_name.  If you used port 5901, it will become server_name:1

How about just trying TeamViewer as PaulNSW suggested?  That should simplify things a whole lot for you.

Through force of habit and since I connect over the internet, I avoid using the built in screen sharing program because it is entirely unencrypted.  That password is set for privacy not security and is sent in plain text across the internet.  For my home systems, I use VineServer (née OSXVNC) and set it up to accept local connections only and connect to the server using an ssh tunnel.  You can tunnel port 5900 to any other port. http://prowiki.isc.upenn.edu/wiki/How_to_Use_VNC_over_SSH

To enable ssh, just go to System Preferences ==> Sharing and check the Remote Login box.  You can then disable Screen Sharing by unchecking the box.  If this were for work, you should get Apple Remote Desktop from the AppStore for $79 and turn on Remote Management in Sharing.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER CERTIFIED SOLUTION
maximus5328

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question