Avatar of Exch10
Exch10
Flag for France asked on

Exchange proxy mail

Hello,

I have a problem to build the SMTP adress of my users, after a lotus migration:

Within my exchange 2007, my Email Adress policy gives %g.%s@mydomain.fr.

All exchange users email adresses are like "firstname.LASTNAME@company.fr" because in my AD, lastnames are uppercase.
I'd like to give proxies smtp like "firstname.lastname@company.fr"
How could I do?
Exchange

Avatar of undefined
Last Comment
Exch10

8/22/2022 - Mon
mmicha

If I read what you are saying...  You have an issue with the system capitalzing the lastname portion of the email addresses when using a policy.

Check out the following article:

http://blogs.technet.com/b/ericnor/archive/2009/04/30/e2k7-creating-custom-e-mail-address-policies-utilizing-various-replacement-string-combinations.aspx

You have to add the following in front of your address structure to keep it all lowercase:

%rAa%rBb%rCc%rDd%rEe%rFf%rGg%rHh%rIi%rJj%rKk%rLl%rMm%rNn%rOo%rPp%rQq%rRr%rSs%rTt%rUu%rVv%rWw%rXx%rYy%rZz

Hope that helps!
ASKER CERTIFIED SOLUTION
mmicha

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ckratsch

This might help:

http://mikecrowley.wordpress.com/2012/05/14/converting-smtp-proxy-addresses-to-lowercase/

Script to pull the current primary, change it to all lowercase, drop it back in, and turn off email address policy for the user account (so that policy doesn't revert these changes).

Couple of problems with that: One, it only addresses existing accounts, not new ones. Two, if you change your email address policy in the future, you'll have to run something to re-enable it for most of your users.
ckratsch

Exch10, even if the method I linked to is the one you used, mmicha's information is much better, because it doesn't create the problems I mentioned in my comment above.

Please have a moderator adjust the accepted solution. mmicha provided an A+ answer.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Exch10

ASKER
Thanks to you. My research arrive to the good solution for me:


Have to install QuestAD commandlets

Get-QADUser -SearchRoot "OU=Users,OU=TestOu,DC=MyDomain,DC=Net" | Select Name, sAMAccountName | Export-csv -path c:\temp\username.csv -NoTypeInformation

Import-Csv c:\temp\username.csv | foreach{Set-QADUser -identity $_.Name -samAccountName ($_.sAMAccountName).Tolower()} | Select-Object Name, samAccountName

Sources