No sound from PC

StuartOrd
StuartOrd used Ask the Experts™
on
I have a laptop on Win XP SP3. It is no longer able to play any sounds (it could a couple of days ago).
Device manager shows all devices working OK
System volume is not muted nor are wave, SW synth and CD player.
It uses Realtek HD audio - looking at its control panel it seems to be normal
I've tried the Windows online help - it found no problems
Neither internal nor external speakers work. I've tested the external ones and they are working.
Can you please suggest what else to try or repeat?
Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
try removing from from device manager and re-install/reboot
First step would be getting the latest drivers from the laptop manufacturer's website or from Realtek directly (I know I sound like cap'n obvious here). Then you will need to remove the existing drivers for the audio chipset and point Windows to the driver packages you've downloaded. In this situation it would be also handy to temporarily get rid of applications interacting with audio (last time I needed to remove Skype)

The fastest way to pinpoint the hardware problem is running a live CD of other Windows (first choice) or Linux OS and play some music to check if the actual hardware is working fine.

Author

Commented:
OK thanks.
I've put an audio CD in and asked it to play with Media Palyer. The fancy visualisations are there but no sound.
I've uninstalled Skype and Skye click to call,  as I recall it's been asking me some questions (update probably) that I've been ignoring recently. No difference so far but I've not rebooted yet.
I've been on the Realtek site now and downloaded what appears to be a driver update. I need to reboot so will get back soon....
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Go to Control Panel, Sounds and Audio Devices, click on the Audio tab, and check that the default playback device (at the top) is set to your Realtek sound card. If it isn't, select it, Click Apply, and then OK.

Author

Commented:
No, unfortunately it still doesn't work. I've tried winamp and Win media player. The volume is up, and device manager shows the Realtek High Def Audio is "working properly" and is enabled.

Author

Commented:
Yes, it is set to be the default device for both output and input.
Go to:

Control Panel>Sounds and Audio Sevices

In the Speakers section at the bottom, click on Advanced

Change the setting there to something else. If it is set to laptop, change it to no speakers, Desktop, etc.

Click on ok/apply

Now go back in and set it back to Laptop and test.

Author

Commented:
OK, I tried that. The default setting had no option but the Realtek, but the advanced setting went to a speaker setup. I set that to no speakers and back to laptop speakers, but it didn't solve the problem.
Just to check again, I went back to the Windows speakers dialogue to check they were still on. Following your line of thought I set it to mute and then unmuted again, and the sound started immediately.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial