Avatar of delpt
delpt
Flag for United States of America asked on

Lync 2010 Remote Call Control with Cisco CallManager Express (CME)

I am trying to set up JUST Remote Call Control (RCC) between Cisco CME and Lync 2010.
I have been able to get Enterprise Voice to work (making calls to extensions from the PC) but the company wants Lync to connect the call with the actual Desk Phone, not the computer speakers/headset.

I have defined a static route using this command:

PS C:\> $TCPRoute=New-CsStaticRoute -TCPRoute -Destination "X.X.X.X" -Port 5060
 -MatchUri "router.domain.com"

PS C:\> Set-CsStaticRoutingConfiguration -route @{Add=$TCPRoute}
PS C:\> Enable-CsTopology

Open in new window


(X.X.X.X being the IP of our CME server)

All of it worked as expected (at least it did not complain).
I then went into topology builder and added a Trusted Application Pool, and Published the topology.

Screenshot of Lync Topology
I then enabled a user for RCC Only in the Lync Control Panel on the Front End server and used the following values for the Line URI and Line Server URI (YYYY being the extension and X.X.X.X being the IP of our CME):

Line URI:  tel:YYYY
Line Server URI: sip: YYYY@X.X.X.X


When I attempt to make a call to an extension in Lync, it appears that calling is completely disabled. All the call icons are greyed out.

Can anyone please point me in the right direction?
Microsoft OfficeVoice Over IPRouters

Avatar of undefined
Last Comment
delpt

8/22/2022 - Mon
delpt

ASKER
Anyone at all?  Please? I've been fighting with this Lync/CME RCC thing for a week.  If anyone has any ideas, I'd be happy to entertain them.
delpt

ASKER
I guess this is too tough for all you experts? :)
mihailpetreski

Hi,
I've never done this with CME before... but, this link looks pretty handy
http://www.cisco.com/en/US/solutions/collateral/ns340/ns414/ns728/ns829/799011.pdf
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
mihailpetreski

You might want to check these links out too - im not sure that CME is a supported IP-PBX with Lync

Vendor Support
http://technet.microsoft.com/en-us/lync/gg131938.aspx#tab=2

Check this too for supported IOS
http://technet.microsoft.com/en-us/lync/gg131938.aspx#tab=1

Also, the attached file might be useful for you -its with CUCM but has some detail that might be handy
Integrating-Lync-Server-and-CUCM.doc
delpt

ASKER
Ironically, CME is only supported for Remote Call Control (RCC), not Enterprise Voice - But Enterprise Voice is the only thing I've been able to get working!!

These documents and links all are for integrating for Enterprise Voice.
Have you had any experience getting Remote Call Control working?

Thanks!
mihailpetreski

I think that you need to enable CTI CSTA in CME in order to get RCC working.
http://scc.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmecti.html

CTI CSA and MOC
http://scc.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmecti.html#wp1236771

Lync uses CSTA to control its associated PBX phone via a SIP CSTA gateway residing on CME.  The Lync client interacts directly with Cisco Unified CME via the CTI interface in Cisco Unified CME to control and monitor IP phones registered in Cisco Unified CME.

Hopefully the above link helps, let me know how you go - i'm quite interested to know if you get it going.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
delpt

ASKER
Well, I've enabled CSTA per the instuctions and enabled CTI watch on every ephone but still no go.

The Lync Client acts like it has no voice enabled and clicking click-to-dial links does nothing. It's quite strange, as there doesn't even appear to be any traffic being sent to the CME system when RCC is enabled.  When Enterprise Voice is enabled, there is lots of traffic.
SOLUTION
mihailpetreski

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
delpt

ASKER
I will try this first thing tomorrow.
Pretty sure I already tried it, but it's worth another shot.
delpt

ASKER
Just tried.

The Lync client complains with an error:
 "Cannot connect to the phone system.  The call control server may be temporarily unavailable. If the problem continues, please contact your support team."

The thing is, I ran a packet trace and I can't see the RCC attempt.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
ASKER CERTIFIED SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
delpt

ASKER
It doesn't function, per Cisco... Am rewarding points anyway for your assistance.
Thanks!