Avatar of Tim
Tim
Flag for United States of America asked on

Clients unable to connect to Exchange through RPC/HTTP

Yesterday i had a problem with my clients being unable to connect to our Exchange server with the mobile devices and I fixed that probelm but now when my clients try to connect to the Exhcange server through the internet using RPC/HTTP in the Outlook they are unable to connect. When I run a test for functionality at this site: https://www.testexchangeconnectivity.com 
The test fails. with this message


Testing HTTP Authentication Methods for URL https://mail.doaminname.com/rpc/rpcproxy.dll.
       The HTTP authentication test failed.
       
      Additional Details
       Exception details:
Message: The underlying connection was closed: The connection was closed unexpectedly.
Type: System.Net.WebException
Stack trace:
at System.Net.HttpWebRequest.GetResponse()
at Microsoft.Exchange.Tools.ExRca.Extensions.RcaHttpRequest.GetResponse()

What do I need to do now to get this fixed?
Microsoft Legacy OSWindows Server 2003Exchange

Avatar of undefined
Last Comment
Shreedhar Ette

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
David Atkin

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Shreedhar Ette

- Browse https://mail.doaminname.com/rpc/rpcproxy.dll you should get blank page after authentication.

- Which Antivirus application being used on exchange server?
Tim

ASKER
I did what you suggested and still no luck. When I went to the RPC and checked to see if Authenticated users had the correct rights it wasn't even there so I added it. I also went to the rpcproxy.dll site and received a blank page but no go when I ran the test on the Remote Connectivity Analyzer.

Also when I check the logs on the server it is still telling me that the secondary virtual directory is still set to use SSL yet when I look at it that checkbox is disabled.

What I nightmare this is.

By the way we are using Trend Micro Worry-Free Advanced on the exchange server.
Tim

ASKER
Oh, and when I go the the rpcproxy.dll page it does not ask for authentication.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
SOLUTION
Shreedhar Ette

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Tim

ASKER
still didn't work. I have been reviewing other forums on this and think I might have configured the virtual directories incorrectly and should delete all the virtual directories and start over. One of the things I have seen is that I was supposed to remove the SSL certificate from the default website before I copied the Exchange directory and created the Exchange-oma directory. I think because of this it keeps saying that SSL is enabled on the Exchange-OMA directory. Your thoughts or am I grasping at straws? What a huge pain this is.

Also, I was looking at my default website and it looks like it has more folders than it should. I have attached a screen shot of my Default Web Site directory for you to look at.
Shreedhar Ette

Post Screen Shot Please...