Avatar of Waynepre
Waynepre
Flag for United Kingdom of Great Britain and Northern Ireland asked on

HP Proliant ML310 G5P

Hello,
I have a problem with one of our servers which is a HP Proliant ML310 G5P with Microsoft Windows Small Business Server 2008 std installed.

About three weeks ago one of our hard drives had failed.
It was a HP Hot Swappable 1TB SATA hard drive which we replaced with a 2TB Hot Swappable SATA hard drive.

Since we replaced the hard-drive the raid has tried to rebuild but it gets to around 77% and then stops and gives a warning alert '776 (Ready for Recovery) Logical Drive 1 (1.8 TB, RAID 5) is queued for rebuilding. '.

We have tried replacing the 2TB with another 2TB, i have tried upgrading the firmware of the E200 Raid controller but we still get the same outcome.

I have attached a screen print of the Status Alert.

I have also attached an updated ADU Report

Any help would be much appreciated

Many thanks

Wayne
Storage HardwareServer HardwareSBS

Avatar of undefined
Last Comment
Waynepre

8/22/2022 - Mon
Alan Hardisty

Why are you replacing a SCSI drive with a SATA drive?

You should be replacing the 1TB SCSI drive with another 1TB SCSI drive, not a SATA drive.
Waynepre

ASKER
Sorry I just tired to edit the question before you replied.

It was a SATA with a SATA.
Waynepre

ASKER
These are the attachments
ADUReport.txt
Array-Configuration.PNG
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Alan Hardisty

So your existing array is a SATA array?
Waynepre

ASKER
yes
NikolasG

Hello.
The problem that you re having can be caused by one of the following causes:
1) More than one problematic drive. Meaning that on of your left drives can still have a problem that stops the rebuilding process (bad sector or hard errors)
2) Raid controller firmware miss match. When you tried to upgrade the firmware of the controller it needs to be done by doing all the upgrades from the version you had to the newest version. E.g if you have 1.3 and want to go to 1.5 you need to go 1.3->1.4->1.5 not directly to 1.5
3) There could be a missmatch due to your SATA drive since from what I get your other discs are SAS. I don't know how well your controller handles heterogeneous raid configurations. I would suggest to use a SAS drive to replace your failed drive.

Hope it helps.
Please feed back.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Waynepre

ASKER
Thanks Alan :)
Alan Hardisty

You are welcome.

I take it you have the BBWC still attached and it is happy?
Waynepre

ASKER
BBWC sorry what does this mean?
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Waynepre

ASKER
Hi Nikolas,
Thanks for the comment

1) this could be the case but wouldn't we see this in the logs?

2) I can't remember if we did this or not and i can;t remember if we upgrade from 1.3 to 1.4 or 1.3 to 1.5 for example. What do you suggest if we upgraded from 1.3 to 1.5?

3) How did you determining the other drives are SAS from what i can see they are SATA please see print screen attached?

Regards

Wayne
Array-Configuration.PNG
Alan Hardisty

BBWC = Battery Backed Write Controller
Waynepre

ASKER
Do you know how i can find out if the BBWC is working? i am just googling it.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Waynepre

ASKER
More Information - Smart Array E200 in Slot 3 Print  

Internal Controller
Controller Status OK
Controller Smart Array E200
Slot 3
Controller Serial Number PA6C90R9SY300C
Bus Interface PCI
RAID 6 (ADG) Status Disabled
Firmware Version 1.86
Rebuild Priority High
Transformation Priority Medium
Surface Scan Delay 15 sec
Number of Ports 2 (Internal only)
Number of Arrays 1
Number of Logical Drives 1
Number of Physical Drives 3
  Array Accelerator
Array Accelerator Present True
Cache Status OK
Array Accelerator (Cache) Ratio 25% Read / 75% Write
Total Cache Size 128 MB
Cache Backup Power Source Batteries
Battery/Capacitor Pack Count  1
Battery/Capacitor Status OK
  Arrays
 SATA Array A
  Logical Drives
 (Ready for Recovery) Logical Drive 1 (1.8 TB, RAID 5)
  Assigned Drives
 1TB SATA Drive at Port 1I : Box 1 : Bay 1
 1TB SATA Drive at Port 1I : Box 1 : Bay 2
 2000.3 GB SATA Drive at Port 1I : Box 1 : Bay 3
  Unassigned Drives
 None
  Spare Drives
 None
  Tape Devices
 None
 
Close Window
NikolasG

Hello again.
At the time that I wrote the answer you didn't have the adu and the configuration image attached, and since you where writing that you replace a SCSI drive I thought it was a SAS drive in a SAS raid.
Saying the above you can take out the 3rd suggestion.
In the atached ADU Report you can see in line 9137 the following error
   Unit Flags                           Unit Flags                      Status  
                                        ------------------------------- --------
                                        Rebuild Aborted From Read Error Critical

That show that the rebuild has been aborted due to read errors.
Can you check if any of the other drives has any read errors.
Please feed back
Waynepre

ASKER
I forgot the mention that so apologies.
According the ADU the other two drives are fine and looking at the hard drive physically the lights indicate that they are processing information.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
NikolasG

In the adu log though it says that the rebuild was aborted due to read errors.
In the Web monitor does it show you any read errors on the other two hard drives.
It is possible a drive to have read/write errors and the light and status not to have switched yet to malfunctioning.
Waynepre

ASKER
Please see attached screen print of the arrary configuration utility
Array Config
NikolasG

Can you do the following click on any of the disks that are still in the array and then click on More information.
From there we can have a full view on the status of the disks.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Waynepre

ASKER
Hi Nikolas
Please see attached
Disk
SOLUTION
andyalder

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Waynepre

ASKER
Hi Andyalder,

The drive in bay 3 is brand new HP and should have firmware.
How can you tell it doesn't have firmware?
Attached is the more info of drive 3, this is the new drive that replace the old 1TB.
Also i have changed this drive twice with two brand new hp 2tb disks.

Drive 3
NikolasG

Hello again.
As andyalder has suggested can you give us a screenshot from the new drives properties also.
Your help has saved me hundreds of hours of internet surfing.
fblack61
andyalder

Must have misread report, HPG1 is correct firmware too. Drive 2 looks like it has read errors on it, that would stop the rebuild from completing and possibly stop a backup rom completing too, search the ADU report for "read errors hard" . (ignore the 0x2104 since they all say that and they haven't all got te same number of errors obviously).

Assuming I'm right and drive 2 has read errors then your only hope is to backup, delete the array and create another one since with 1 missing disk and one with errors on it you may never get it to rebuild. There is controller firmware to get it to skip over bad blocks during rebuild so it completes but it can't fill the data in for the skipped sectors so just puts zeros in their place.

There is new firmware for disk 2 but I doubt it would help since it doesn't address read faults, http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=329290&prodSeriesId=3642804&swItem=MTX-29357b82266147b3a610c3e3be&prodNameId=3863113&swEnvOID=4064&swLang=8&taskId=135&mode=5
Waynepre

ASKER
I tried installing this firmware last Thursday and you are correct it hasn't made any difference.
If we go ahead and delete the array as far as i know this will delete all data or is there away to delete the array and recreate a new one with out losing all the data.

Also, what are the chances of the new 2tb actually completed rebuilding but the logs not showing it.

I was thinking about turning the server off, take out HDD 2 and switch back on again and see if the server boots up.

If it doesn't then we know that the 3rd hard drive has rebuilt and then we would insert HDD 2 back into the bay.

Do you know if this could case any additional errors / issues?
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Waynepre

ASKER
Thanks Andy, I will try removing disk 2 tomorrow around 20:00.

I will update the question with the outcome.

With regards the backup, luckily we get a full backup every day.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER CERTIFIED SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Waynepre

ASKER
Just to give a final update - we decided to do a complete upgrade on our network so we no longer have any issues.

Thanks to you all for helping.