Remove a copy of a Project under Source Safe Control and run it locally on a laptop

cmdolcet
cmdolcet used Ask the Experts™
on
I have a project that is under the Source Safe Control ( Source Safe 6.0d) I would like to run this project in vb 2005 on a more portal laptop, however I do not know how to detach the files so that it run run on both Machine. I would like to run ( debug) the project on a more portal PC.


Thanks in Advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2011
Commented:
You can copy the whole folder for the project, delete the files *.*scc, then open the project from the new folder and detach it from VSS. I guess there will be a question "Do you want to permanently detach ..." ( I don't remember exact wording).
You can also go to menu File ->Source Control -> Change Source Control ... and unbind the project

Author

Commented:
If I look under the main root folder on my VSS. I see two folder one is my program folder and the other is an install folder. Inside me program folder I have the bin, myproject, resource and all the .vb files.

Do I need to copy this entire folder?

Under the install folder I have my debug and Release folders and the mssccprj and Install and Install.vdproj

Do I need to copy this entire folder?

Under both folder I see a file called vssver. I am assuming you delete this file and then load the project onto the PC itself?

Author

Commented:
I copied all the project folders to a flash drive and then pasted them on the offline PC. I then went into every folder and deleted all *.*scc files. I then open up VS 2005 and I was prompted by a popup to unbind the solution I did and then it was able to open up in the debug window of the VS. When I went to run the project in debug mode it gave me the following error "The binding handle is invalid".
Introduction to R

R is considered the predominant language for data scientist and statisticians. Learn how to use R for your own data science projects.

Top Expert 2011

Commented:
Did you go to the menu File ->Source Control -> Change Source Control ... and unbind the project ?

Author

Commented:
I still want to keep my main project under source control, however all I would like to do is copy the project and place it on the new PC. The new PC btw doesn;t have source safe on it.
Top Expert 2011

Commented:
You wil unbind the project from the new folder. The old one will remain under VSS.

Author

Commented:
how can I do that. I dont have VSS on the new PC.
Top Expert 2011

Commented:
You shoud do this from Visual Sudio - go to the menu File ->Source Control -> Change Source Control ... and unbind the project

Author

Commented:
ON the new PC that is running the VS 2005 I do not have that option for Source control (that is because VSS is not on the new PC). Should I then go into the old PC and do it from there?

Keep in mind I still want my project under the VSS on the old PC I just want to have an offline copy that I can run and make changes on fly on a laptop.
Top Expert 2011

Commented:
No, this is enough. What you can do is to right click on the project folder in Windows Explorer - select menu Properties and uncheck ReadOnly check box in tab "General". This check box may be checked /unchecked and third state. Make sure it is unchecked. Click OK and ther will be a question if you want to apply the settings for the subfolders - select the option to apply them.

This is necessary because the non checked out files are read only in VSS

Author

Commented:
I go onto the new C find the main folder and follow the direction. It ask me if I want to apply the settings for the subfolders and I say yes. I exit the folder properties window and go back into the properties window and the read only box is checked again. THe new PC laptop OS is XP SP3. It seems like I can't change the read only properties. I can however Build the project and it builds correct. It just will not run under the Debug or Release modes.
Top Expert 2011

Commented:
Make sure that the files were not open while you change the readonly flag. You may also delete "bin" and "obj" subfolders
Commented:
OK I was able to find a solution as far as deleting all the .scc files in each folder you go into the Project >> ProjectName Properties >> DEbug >> and uncheck the "Enable the Visual Studio Hosting".

Author

Commented:
On top of deleting all the .scc files if you follow the path outlined in my comments the is te corerct solution

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial