Avatar of stevehavert
stevehavert
Flag for United States of America asked on

Exchange Server not accepting mail from .US domain

I recently set up SBS 2011 for a client.  Everything works except that e-mail from one particular customer is not being received.  I've looked in the Tracking Log and no e-mails from that address appear.  The domain ends in .US instead of .com and I'm wondering if that has something to do with it.  I've looked at the receive connector, transport rules, etc. in Exchange and nothing looks like it would restrict mail from a certain domain.  

I checked the sender's domain to make sure they weren't blacklisted. Their IP address came back clean.  I added the IP address to the While List in the Exchange spam filter thinking it was being blocked as spam, but that didn't fix the problem.  

If the sender copies me on his e-mail, I receive it through my POP account.
Microsoft Legacy OSMicrosoft Server OSSBS

Avatar of undefined
Last Comment
stevehavert

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
arnold

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
stevehavert

ASKER
My client has not contacted me again about the problem.  It may have fixed itself.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck