Link to home
Start Free TrialLog in
Avatar of onyourmark

asked on

a sheet always opens when I open Excel

Every time I try to open up Excel there is always an extra sheet or workbook that opens. How can I not have it open always?
Thanks very much.
Avatar of John
Flag of Canada image

In Excel go to Options. In the general tab, there is an option to set the number of worksheets. I set mine to 1 and no extra sheets open. Works all the back to Office 2003 if I remember correctly. I am using Office 2010. ... Thinkpads_User
Avatar of onyourmark


Hi. Thanks a lot. Actually, I did not explain this correctly. It looks like an extra workbook is opening (it shows up as an extra icon on the quick launch bar).
Quick Launch went away a long time ago, and so the icon may be corrupted.

Delete ALL your Office quick launch icons and then do an Office Repair. How to do the repair depends on the version of Office and Office 2007 is the trickiest to repair correctly. The Repair function remakes icons (amongst other things).

What is likely happening is that you are opening another occurence of Excel (maybe from Quick Launch) instead of using the existing occurence in the Task Bar.

... Thinkpads_User
Maybe I am using the wrong words. I am just talking about the bar at the bottom of my screen. I am not sure what it is called. It shows icons for each open program. If I click on an Excel program on my desktop, more than one icon shows up on that bar. Also this extra workbook opens in Excel in addition to the one I clicked on. This extra book is called salary.xlsx and it is a workbook I made a while back.
Excel is (and has long been) capable of opening in multiple instances - each instance being a workbook. That sounds like what is happening here.

The first step would be to restart your computer, and open Excel the program (not by double clicking a XLS file). Excel should open only one instance. If carefully opening one instance creates two instances of Excel, then do an Office Repair as I noted.

Second, if you are opening by file association (double clicking on the filename), verify that (a) you only have one version of Office (Excel) installed and (b) that the association (default programs) points to Excel and then (c) there is only one association for .XLS .

Third, once Excel is open, double clicking on the Excel Program icon or double clicking on another filename will open another instance of Excel. I generally close Excel when I am done with it to avoid issues.

Finally, make sure that salary.xls is not trying to autostart. It could be doing that.

.... Thinkpads_User

... Thinkpads_User
Hi. What is autostart? How do I check that?
It is generally done with macros, so check your macros in Excel and look in your startup folder that there is nothing related to Excel in there.

I do not use such features, but I am trying to understand why, if you are certain you have never opened salary.xls after starting the computer, that it is running anyway. Something must be starting it, but I do not know what.

In order to make some progress here, try closing Excel after you have used it once. That is, open a file, work with the file, save the file and close Excel. Do this another couple of times, closing Excel each time. Is anything still open?

.... Thinkpad_User
The key thing we need here (using your filenames) is this: Does salary.xls open without ever opening Excel, and then if so, why.

.... Thinkpads_User
Hello. It opens whenever I open any excel file.
So then you have a macro in Excel or a macro in salary.xls that is opening it.

If the issue is restricted to salary.xls, open salary.xls, open a new sheet, copy the data and formulas from the old sheet to the new sheet (do not copy the whole sheet). When done, close salary and then move it onto a DVD or a spare server folder. Then save the new sheet as salary.xlsx and see if the behaviour continues.

You might also consider uninstalling Office, restarting and reinstalling Office (Full, not Typical) to get rid of Excel macros. Be sure to update all the service packs and patch fully. If the first method works, uninstall may not be necessary.

.... Thinkpads_User
Something I might try is this:  Copy salary.xls to a safe location away from where Excel looks. Then rename it to something very different (compensation.xls). Restart. Does compensation start when another file is opened?  

... Thinkpads_User
Avatar of byundt
Every file stored in the XLSTART folder will open when Excel does. Note that you may have more than one of these folders, and that it (they) may be hidden. If you move the file out of XLSTART, it won't open when Excel launches.

You can also specify another folder to open files in automatically when Excel launches. In Excel 2010, you specify this folder in File...Options...Advanced "At startup, open all files in..." menu item (near the bottom of the pane on right). Excel 2007 has a similar option (only you press the Office icon at top left rather than use the File menu on the ribbon). Excel 2003 keeps it in Tools...Options...General.

Try doing a File...Save As with salary.xls and note the path.
Hi byundt. Thank you.
This folder is empty C:\Program Files\Microsoft Office\Office14\XLSTART
but this folder
contains Personal.xlsb and salary.xlsx.
Can I take one or both of these out?
Yes. Move them to a safe location so that they are not lost. Copy them back to a standard folder and rename them to be sure.

.... Thinkpads_User
Avatar of byundt
Flag of United States of America image

Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
@onyourmark - If you are using Macros (as we discussed earlier) you should know what macros you are running.  Macros are under the View tab in Excel 2010. .... Thinkpads_User
Thanks for the easy solution!
@onyourmark -- Not even an assit from you for all I offered?  Thanks.
.... Thinkpads_User