Avatar of EricHoma
EricHoma
Flag for United States of America asked on

Need help with Cisco/LinkSys RV016 Configuration

I have an RV016 dual-WAN router that I am attempting to set up.  I have a T-1 with a 32 IP block, static addresses, on WAN1.  A 10mb Wifi coming into WAN2.  On the Wifi side they have instructed me to use DHCP to get addresses from their router (gateway) although they are supplying me with 5 public addresses through NAT at their data center.  The Wifi router supplies me with 10. addresses.

I have set the LAN side of my router to DHCP.  I have a couple of servers running so I needed to run NAT to pass public addresses to the servers.  I need to be able to use a work station computer on the LAN side of my network and appear as a fixed IP coming into a clients network in order to pass through his firewall.  We can set rules in his firewall to allow an IP from each of my WAN nets but I can't seem to figure out how to bind the work station to one outbound IP address.  Any help would be appreciated!
RoutersNetworking Hardware-OtherNetworking

Avatar of undefined
Last Comment
akahan

8/22/2022 - Mon
akahan

Give the machine that needs to punch through your client's firewall a static IP address on the LAN (or use DHCP Static IP in the router to give it a static IP address matched to its MAC address.)

In the router configuration, go to Setup, then One-to-One NAT.

1. Enable One-to-One NAT: If you check the box, One-to-One NAT will be enabled.
2. Private Range Begin: Enter the static LAN IP address of the machine that needs a consistent WAN IP address.
3. Public Range Begin: Enter the WAN IP address you want to use for that machine (it would have to be one of the 5 assigned to you, and not the same one as is used as the router's own WAN IP address)
4. Range Length: Enter 1, since you're only doing this with one machine.

That machine should now be consistently seen by the outside world (and therefore your client's firewall) as the WAN address you selected in #3 above.
EricHoma

ASKER
I believe that I have done/tried that.  My DHCP leases out 192.168.1.100 through 192.168.1.149.  I set up NAT from all of my public IP addresses from my T1.  173.XXX.XXX.200 through 173.XXX.XXX.229 NAT to 192.168.1.200 through 192.168.1.229 respectivly.  I then set the router to always assign 192.168.1.200 based on the mac address of the client work station.  I confirmed that it does always grab .200 but it still establishes connection through the other network.  It seems that the NAT only works for inbound traffic, not outbound.  I also tried setting the client work station to a static IP of 192.168.1.200 but it did not make any difference.
ASKER CERTIFIED SOLUTION
akahan

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
EricHoma

ASKER
I just tried "Bandwidth Management" and created two rules for the work station at 192.168.1.200 which is the IP that it issued to it by DHCP due to the mac address rule.  I set two rules for that IP only, WAN 1, all services (ports), one for upstream and one for downstream.  I set the minimum rate at 1 meg and the max at 1.5 meg.  I saved the rules and rebooted the router.  Checked to make sure that the rules were still there and checked the public IP that I was seen at.  It stills latches onto the WAN2 network.
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
akahan

Ok, but did you try what I suggested?
EricHoma

ASKER
Yes, I believe that is what I did.  Load Balance is under the Bandwidth Management tab under System Management.  It lets you select a WAN port and then a service.  It would seem that if I tell it all services from .200 through WAN1 then I would be going out WAN1 but it doesn't.
akahan

I think you may be on the wrong page.  Go to SYSTEM management, not bandwidth management, select dual wan, then go from there.  We're shooting for protocol binding, not preferences.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
EricHoma

ASKER
You're right, I was in the wrong place.  That did the trick, that work station on that IP is now bound to WAN1.  Thank You!
EricHoma

ASKER
Thanks again, I've been battling this for hours.  My confidence in Expert's Exchange has been renewed!
EricHoma

ASKER
Something interesting happened once I made that change.  That work station can no longer browse the web server that on the LAN side of the same router.
Your help has saved me hundreds of hours of internet surfing.
fblack61
akahan

excellent, glad to hear it!
EricHoma

ASKER
Ok, had to enter a destination network or it played havoc with looking at my own web server from inside the LAN.  Wierd but working good now, thanks again.
akahan

Sorry, the "excellent, glad to hear it!" comment was in response to your "thanks again..." post, not the post about the workstation no longer browsing...   Anyway, glad you got that one solved too.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.