Cisco 1801 Interfaces - using interfaces to route traffic

ccfcfc
ccfcfc used Ask the Experts™
on
I am using a Cisco 1801 router. It has the normal FE0 plys FastEThernet1-8 interfaces .

Can I utilise the interfaces FastEthernet1 -8 ? Will the 1801 then manage routing of traffic.
Do I need to assign each VLAN to a separate FastEternetX or will the 1801 manage this and route accordingly ?

So I am using FE0 as OUTSIDE and want to simulate customers connecting via the internet to a service by IP address. This service will sit on a server in a VLAN "DMZ" which ideally I would to plug into one of th FastEthernetX interfaces. Do I need to assing an IP address to each one of the Physical interfaces or will 1801 know what to do with it having traffic coming in from these interfaces ? How do I assign or do I not need to assign an interface to a VLAN ?
Hope this makes sense.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Create a VLAN and assign a ip address/subnet ; after that you can assign the interfaces to that newly created VLAN.(by adding "switchport access vlan #" to that interface). The route to the internet is being setup by the "route" command.

so to give you an idea:
_________________________________________
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.0.0.254 255.255.255.0
!
interface Vlan2
  nameif outside
 security-level 0
 ip address 1.2.3.4 255.255.255.248
!
interface Vlan3
 nameif dmz
 security-level 50
 ip address 192.168.1.254 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2

interface Ethernet0/5
 switchport access vlan 3
_________________________________________

>> by not setting a switchport, other interfaces will be in de VLAN 1 <<
Commented:
Hello

Fe0 port is a Routed port -

packets from this interface going to another must be routed
where both the interfaces in question will be on different subnets

F1-8 ports are switch ports -

packets from this interface going to another must be switched
where both the interfaces in question will be on the same broadcast domain
However if they are on different broadcast domain/subnet the packet must be routed and a SVI is required


Basic example config below


ip routing

interface Fe0
description >>>> WAN INTERFACE <<<<
ip address 10.1.0.1 255.255.255.252
no shutdown

interface fe1
description >>>> SERVER A - VLAN 10 <<<<<
switchport mode access
switchport access vlan 10
no shutdown

interface fe2
description >>>> SERVER B - VLAN 20 <<<<<
switchport mode access
switchport access vlan 20
no shutdown

Interface vlan 10
description >>>> SERVER A - GATEWAY <<<<<
ip address 10.1.1.254 255.255.255.0
no shutdown

Interface vlan 20
description >>>> SERVER B - GATEWAY <<<<<
ip address 10.1.2.254 255.255.255.0
no shutdown


HTH

Commented:
vlan 10
name SERVER A

vlan 20
name SERVER B
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Then via access-list I control traffic into OUTSIDE FE0 which based on rules will route traffic to the desired VLAN .
Commented:
Yes access-list will be attached to outside Fe0

Traffic will be successfully routed to desired VLAN  via its respective connected SVI interface

A default route might also be required to route all traffic via Fe0

Author

Commented:
So how do I ensure/route all traffic. Do I set a route on each interface(Vlan 10 and VLan20)  to the WAN/outside interface ?

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial