Asterisk Call recordings

alexanderfoti
alexanderfoti used Ask the Experts™
on
I currently use asterisk 1.4 with free pbx on top.

I am using Activa TSP tapi drive and dial engine pro so that I can dial from outlook and call to links. Whilst this works fine, I have noticed that calls aren't recorded when dialling with this method. All calls are set to be recorded but it seems as though the flag isnt being set to record the calls.

Any ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Have you ruled out entirely that calling from an IP Phone actually generates a recording?

Author

Commented:
yes, without using click to dial via TAPI, calls are recorded correctly.

Commented:
What version of freepbx are you using?

I think you are right in that it is a issue with the flag and how freepbx checks if it should record a call or not.

When you make a call through the TAPI setup Asterisk is originating a call via the manager interface.  I suspect that the call is not getting flagged at all or there is some kind of conflict such that the flag is dropped in the way the call is sort of transferred when the originate places the call.

May need to force the flag with some custom context or something.  I was setting up a freepbx test box later this week and can check into it closer then.
Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!

Author

Commented:
Many thanks,I will figure check the versions and get back to you tommorow

Author

Commented:
I am running Free pbx version FreePBX 2.9.0.12 and asterisk version Ver. 1.4.39, the context for calls using Tapi and dialing directly is "from-internal"

Author

Commented:
Any luck?

Author

Commented:
I have done some testing today, If I use OUTcall, which is a program that dials in a similair way, the call recordings work correctly.

Things I have noticed in the calls logs, when dialing with Activa TSP, the call trace shows:

AMPUSER=Sip/100
and
CALLERID(number)=SIP/100

Whereas when I am dialing with Outcall (and the calls are recorded correctly) it shows:

AMPUSER=100
and
CALLERID(number)=100

any ideas?
With no response to this, I turned to a piece of software called ADAT, which ammends the call records so asterisk calls correctly.

Author

Commented:
I fixed it.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial