Avatar of alexanderfoti
alexanderfoti
Flag for United Kingdom of Great Britain and Northern Ireland asked on

Asterisk Call recordings

I currently use asterisk 1.4 with free pbx on top.

I am using Activa TSP tapi drive and dial engine pro so that I can dial from outlook and call to links. Whilst this works fine, I have noticed that calls aren't recorded when dialling with this method. All calls are set to be recorded but it seems as though the flag isnt being set to record the calls.

Any ideas?
IP TelephonyVoice Over IPTelecommunications

Avatar of undefined
Last Comment
alexanderfoti

8/22/2022 - Mon
José Méndez

Have you ruled out entirely that calling from an IP Phone actually generates a recording?
alexanderfoti

ASKER
yes, without using click to dial via TAPI, calls are recorded correctly.
kode99

What version of freepbx are you using?

I think you are right in that it is a issue with the flag and how freepbx checks if it should record a call or not.

When you make a call through the TAPI setup Asterisk is originating a call via the manager interface.  I suspect that the call is not getting flagged at all or there is some kind of conflict such that the flag is dropped in the way the call is sort of transferred when the originate places the call.

May need to force the flag with some custom context or something.  I was setting up a freepbx test box later this week and can check into it closer then.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
alexanderfoti

ASKER
Many thanks,I will figure check the versions and get back to you tommorow
alexanderfoti

ASKER
I am running Free pbx version FreePBX 2.9.0.12 and asterisk version Ver. 1.4.39, the context for calls using Tapi and dialing directly is "from-internal"
alexanderfoti

ASKER
Any luck?
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
alexanderfoti

ASKER
I have done some testing today, If I use OUTcall, which is a program that dials in a similair way, the call recordings work correctly.

Things I have noticed in the calls logs, when dialing with Activa TSP, the call trace shows:

AMPUSER=Sip/100
and
CALLERID(number)=SIP/100

Whereas when I am dialing with Outcall (and the calls are recorded correctly) it shows:

AMPUSER=100
and
CALLERID(number)=100

any ideas?
ASKER CERTIFIED SOLUTION
alexanderfoti

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
alexanderfoti

ASKER
I fixed it.