Avatar of statpro
statpro
Flag for United Kingdom of Great Britain and Northern Ireland asked on

SCCM OSD fails Applying Driver Package

Hi,

I'm having issues with deploying an operating system at the point when it wants to apply the driver package.

I have attached the smsts.log file as someone might be able to tell me where im going wrong.

Please ask questions and I will explain what you need to know.

Regards,

Scott
smsts.log
Microsoft ApplicationsMicrosoft Server AppsMicrosoft Legacy OS

Avatar of undefined
Last Comment
Kezzi

8/22/2022 - Mon
Kezzi

what is the final error message you get onscreen?  This log file just seems to stop at the point it tries to download the driver package locally.  Have you configured your WebDav settings correctly?
statpro

ASKER
If I remove the driver package from the task sequence then the operating system along with all my specified software installs without an issue.

The final error message I get is: (0x80091007)

I had to redo the install again to get the error code and the drivers did start copying. Please see attached version 2 of the log file.

Just to note and I'm not sure if this is linked to the issue or not but my drivers are stored on a NAS box. I have set the security of the NAS shared folder to allow the server full access to the folder along with domain admins.

Your help is much appreciated.

Regards,

Scott
smsts.log
Kezzi

your log file is empty?
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Kezzi

have you tried updating you distribution point for that driver package to create a new hash file and see if that works?  Is the properties of your TS to run from DP or download locally before running?  if its download, have you tried changing your Advert for the TS to run from DP?
statpro

ASKER
Please find attached file
smsts.log
Kezzi

its getting to the same point as the previous ones.  Its failing to download the driver package before running, this could be that the hash of the driver does not meet the hash on the DP, which is why i state to either update your DP with a fresh set of files, and/or change your advertisement for your task sequence to run from DP,.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
statpro

ASKER
I'm not sure I understand what you mean.

Would you be willing to look at the live environment?

Regards,

Scott
Kezzi

How are you deploying your driver package.  I assume this is a package you created under your Driver Package node in the console, which you then distributed to your NAS share.

You also woud have advertised your Task Sequence to run against a specific collection, so you need to try ammending your Task Sequence advertisement to Run from distribution point instead of download content lcoally before running, this is on the distribution point properties of the advertisement.
statpro

ASKER
Hi Kezzi,

Please find attached some screen prints of my setup.

Regards,

Scott
Capture1.PNG
Capture2.PNG
Capture3.PNG
Capture4.PNG
Your help has saved me hundreds of hours of internet surfing.
fblack61
ASKER CERTIFIED SOLUTION
Kezzi

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Kezzi

Have you run through the Validate option on the Content Locations to see if it the files match from source to DP?
statpro

ASKER
I haven't done any copying.

Please tell me what to select.

Regards,

Scott
statpro

ASKER
Validation run successful.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Kezzi

OH!  ignore my 2nd last comment!   i was wrong in thinking you were manually copying the content, just noticed you hadnt enabled the option that had the manual selected under it.
Kezzi

Can you show me screen shots of your TS advertisment?
statpro

ASKER
where in 2012 can i show you this?
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
statpro

ASKER
do you have an email address i could use to do a lync screen share?
Kezzi

I dont use Lync.

How did you advertise this task sequence to a collection?
If you go to your adverts node, can you see the advert for the task sequence?
statpro

ASKER
You dont need to use Lync to do a screen share. I can send you an invite.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
statpro

ASKER
Kezzi

when you deploy your task sequence, you can see in this picture that you have the option of downloading the content when needed, or running off the distribution point.  

I dont really want to post my email address on here... sorry.
dp-settings.png
statpro

ASKER
I dont have them options.

My get them when i advertise my install task but not when i advertise the driver package. if you want to send me your email address to scott.walker@statpro.com I will start a sharing session.

Regards,

Scott
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Kezzi

It is on the Task Sequence Advertisement/Deployment that you need to specify this.

You dont need to advertise your driver package.