Avatar of wrenmott
wrenmott
 asked on

PXE - proxyDHCP not responding on port 4011 (SCCM 2012)

Hi all -

Though I've read through every related article on the subject I still find myself in a bind.  Bottle of virtual champagne for anyone who can assist.

We're running SCCM 2012 and have a distribution point configured.  It sits on one subnet while our DHCP sits on another.  I have IPhelpers configure to forward DHCP requests to both the DHCP server AND the WDS.  I also have options configured in DHCP to point to the deployment server which you can see in the trace.  The machine gets the correct info which you can also see in the trace.

Never the less, the PXE client fails to make the connection and errors out with the dreaded "proxyDHCP failed to respond on port 4011" message.

I'm at a loss.  I don't know how to proceed with troubleshooting as I am out of ideas.

Firewalls, both physical and software, are not the issue as everything is open.

Can someone nudge me in the right direction?

Regards,


Wren
DHCP-Offer.PNG
Microsoft Server AppsNetworkingWindows Server 2008

Avatar of undefined
Last Comment
vivigatt

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
vivigatt

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
SOLUTION
d_nedelchev

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
d_nedelchev

Just to be sure that all services are up run 'netstat -abn' on the WDS server and look for the following lines:

  UDP	10.220.39.25:67		*:*
  DHCPServer
 [svchost.exe]
  UDP	10.220.39.25:68		*:*
  DHCPServer
 [svchost.exe]
  UDP	10.220.39.25:69		*:*
  WDSServer
 [svchost.exe]
  UDP	10.220.39.25:4011	                *:*
  WDSServer
 [svchost.exe]

Open in new window


I presume that this is your WDS IP.
wrenmott

ASKER
Hi all-

In the end (just minutes ago, in fact) I found this post regarding option 43.  It took me days to track down and I am not even sure this was the fix in the end.  Its very archaic.

http://nssadoc.blogspot.co.uk/2008/06/differential-analysis-wds-dhcp.html

In the end these are the steps I took to solve the issue.  We have WDS and DHCP running on two different servers on two different subnets.

1.  Configured IPhelpers on our routers/switches to forward DHCP requests to both the DHCP server and the WDS server (both options not to listen were of course checked)

2.  Configured IPhelpers to forward all traffic destined for UDP port 4011 to our WDS server.

3.  Configured options 43, 60, 66, and 67 with corresponding values.

And that turned out to be the magic recipe!  Now, it could be that if I had time to reverse engineer everything some of these steps or configuration of some options (60, for example) could be overlooked but it in the end the above steps is what got us to a working state.

Splitting points between the two of you for your time.

If you have any further thoughts on this I would love to hear them.  This issue has been the bane of my existence for a week and a half.

Wren
vivigatt

Option 43 is usually not to be set manually, the PXE service (WDS in your case) is supposed to set this, and to do it dynamically.

AFAICT, with your configuration you should have:
1/
IPhelpers for DHCP broadcasts to the DHCP AND the WDS server.

2/
UDP 4011  is not used in that configuration, so no need to add entropy by adding anything related to it.

3/
Regarding the DHCP options, you should set... NONE OF THEM !
Why ?
In your configuration, the PXE client should receive a DHCP offer from the DHCP server, AND an "extra DHCP offer" (with no IP address in it) from the PXE server. This "extra DHCP offer" would contain DHCP options 66 and 67 and 43 (or their equivalent. Actually, you can do it all with Option 43 IIRC, but most PXE services do set these 3 options).

If you set explicitly DHCP option 66, 67 and 43 in the DHCP server, you take the risk of overwriting the "real" PXE configuration.

Hope this helps
Your help has saved me hundreds of hours of internet surfing.
fblack61