Avatar of backoffice
backoffice
Flag for United Kingdom of Great Britain and Northern Ireland asked on

Unable to replay restored transaction logs to restored edb using eseutil /r for Exchange 2010

I am testing my backup and restore process for Exchange 2010.
I have used 2 different products to backup Exchange 2010. After performing restores using both products I then tried to apply to my restored transaction logs to my restored edb using eseutil /r but it failed each time.


Information Store Server Spec is:
Windows Server 2008 R2 Standard SP1
Exchange 2010 Enterprise Edition SP2 (Version: 14.02.0247.005)
8GB RAM


The steps I followed are listed below with results.

eseutil /mh F:\RECOVERYDB\Mailbox\M-O\M-O.edb
Resulted in confirmation that database is in a "Dirty Shutdown" state.

eseutil /ml F:\RECOVERYDB\Logs\M-O\E06
Resulted in no damaged log files

eseutil /r E06 /i /l F:\RECOVERYDB\Logs\M-O /d F:\RECOVERYDB\Mailbox\M-O\M-O.edb
Resulted in failure to run and advised to run with /a

eseutil /r E06 /i /a /s F:\RECOVERYDB\Logs\M-O /l F:\RECOVERYDB\Logs\M-O /d F:\RECOVERYDB\Mailbox\M-O\M-O.edb
Resulted in operation successful

eseutil /mh F:\RECOVERYDB\Mailbox\M-O\M-O.edb | findstr "State:"
Resulted in confirmation that database is still in a "Dirty Shutdown" state with log required unchanged

eseutil /p F:\RECOVERYDB\Mailbox\M-O\M-O.edb /t F:\EDBTemp\
Resulted in operation successful but with data loss


Why am I unable to successfully replay my restored transactions logs against my restored edb?
ExchangeStorage SoftwareWindows Server 2008

Avatar of undefined
Last Comment
backoffice

8/22/2022 - Mon
Postmaster

Have you removed the checkpoint file? - this should make exchange look for logs to play.
backoffice

ASKER
I tried already removing the chk file and ran the eseutil /r and it completes successfully but I still have a "Dirty Shutdown" state for my edb.
backoffice

ASKER
and still requires logs files
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
backoffice

ASKER
Created ulVersion: 0x620,17
     DB Signature: Create time:03/03/2012 15:07:48 Rand:2111575 Computer:
         cbDbPage: 32768
           dbtime: 9412830 (0x8fa0de)
            State: Dirty Shutdown
     Log Required: 54314-54333 (0xd42a-0xd43d)
    Log Committed: 0-54334 (0x0-0xd43e)
   Log Recovering: 0 (0x0)
Postmaster

perhaps this will help.
http://technet.microsoft.com/en-us/library/bb123479(EXCHG.80).aspx

Are you placing the to-be-palyed transaction logs in the same DIR as the exisitng log files?
ASKER CERTIFIED SOLUTION
backoffice

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
backoffice

ASKER
it worked!
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.