Link to home
Start Free TrialLog in
Avatar of Barthax
BarthaxFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Autodiscover service making life with Outlook 2007/2010 hell

Hi,

We have a customer that has migrated their SBS 2003 Exchange install to Exchange 2010 on a new Windows 2008 R2 server.  All Outlook 2003 clients and iPhone/iPad clients are working fine with the migration.

Outlook 2007 and Outlook 2010 clients, however, continuously nag the user for credentials to log into exchange2010.livemail.co.uk.  These clients perform all the normal activities - sending, receiving, etc.  When not using cached mode, a manual Send/Receive will collect the new e-mail and then pause at about 98% of the receive connection.  After about a minute the client will then ask the user for credentials to log into exchange2010.livemail.co.uk - something the customer has never been a part of nor do they have an account.

After some research, I can confirm that the Exchange 2010 installation:

- Has "Get-ClientAccessServer | fl AutoDiscoverServiceInternalUri" set to their internal server's "https://<server>/Autodiscover/Autodiscover.xml" URL.
- Has "Get-AutoDiscoverVirtualDirectory | fl InternalUrl, ExternalUrl" both set to their internal server's "https://<server>/Autodiscover/Autodiscover.xml" URL (they have no external Outlook clients).

I have discovered Microsoft Knowledge Base Article 2480582 and have altered the registry on these workstations to include the internal server's address (removing the exchange2010.livemail.co.uk entry there).  This made no changes.

This is a small company with one Exchange server, no requirement for external Outlook clients and no affiliation/requirement for exchange2010.livemail.co.uk.  How can the installation be configured to prevent this CONSTANT nagging for exchange2010.livemail.co.uk credentials?
SOLUTION
Avatar of ckratsch
ckratsch
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Barthax

ASKER

There is no autodiscover.contoso.com (equivalent) domain for the customer.  Why would there be when everything required of the server is internal.  Note: the AD domain is atypical SBS 2003: "<company>.local" whereas the live DNS domain is very different.  Just to clarify: you don't mean "autodiscover.<company>.local", do you?

Thanks for the pointers on Outlook, will check them.
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Barthax

ASKER

Thanks for the links - I will go through them shortly.

The Outlook options you mention do not exist.  CTRL+right click does not give a different menu from the normal right-click menu (a series of which messages to display to the user and whether to open outlook).
No, no, not the taskbar icon to launch the program - when Outlook is running, there's an Outlook tray icon next to the clock. Might be autohidden, but there should be a little arrow on the edge of the tray to expand the hidden icons. This is all where the network and audio icons show up.
Avatar of Barthax

ASKER

Hehe, yeah, that's the icon I was referring to: next to the clock, click the up arrow to see the hidden icons, then right-click or CTRL+right-click: there's no difference.

However, that all said, there really is an autodiscover.<DNS-domain> which no-one seems to have been aware of.  I can only guess at some stage, someone had agreed to a demo of the livemail.co.uk service and it had been created.

Much obliged. :)
Avatar of Barthax

ASKER

Spot-on: the autodiscover sub-domain existed and was pointing to the incorrect location.  The link to the Tim Harrington article (http://blogs.catapultsystems.com/tharrington/archive/2010/09/17/troubleshooting-the-client-access-server.aspx) included a subsequent link to a https://www.testexchangeconnectivity.com/ which aided the discovery of the autodiscover sub-domain.
Darn, I almost recommended testexchangeconnectivity, too, but I didn't put together that it would be internet-facing for some reason. That you have ActiveSync devices should have told me that.

Glad you got it sorted out.
Avatar of Barthax

ASKER

Whatever you do, don't second-guess gut-instinct.  Your first sentence in your first answer was the reason & I just didn't believe it - thinking I'd ruled it out through other means, I didn't check thoroughly.  Everything else just guided me back to your first sentence.  Thanks again. :)