How to change screen resolution in full screen in Microsoft RDS or VDI environment without changing the resolution of the client

cdron
cdron used Ask the Experts™
on
Hello!

Is there a way to change the resolution of your RDS/VDI session to let's say 800 by 600 without changing the resolution of your notebook which has a resolution of 1920 to 1200 and still be in Full screen in de RDP session?

Or do I need additional software like VMware view or Xendesktop?

Regards,


Ron
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
When you open the RDS client it has an option to set the screen size.  Citrix has similar options if the admin has allowed user override.
you can set screen size under application properties and set the screen size.

Author

Commented:
Hello,

I know I can set the screen size to a smaller resolution. But then it is not Full Screen.

That is exactly the problem.

Regards,

Ron
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
One of the options in RDS is "full screen".  After all the resolutions.

Author

Commented:
Yes, that's true but then the resolution is the same as my laptop, 1920 by 1200.
That is not what I wan't. I wan't the resolution to be 800 by 600, full screen.

Commented:
You can't have both.  Either it is full screen or it is 800x600.  The very definition of full screen is the current desktop resolution.

Author

Commented:
OK But is this also the case with VDI?

A week ago somebody show me a laptop with resolution 1920 by 1200 and a Windows 7 VDI session with resolution 1024 by 768 in Full screen.

How is that possible then?
Nagendra Pratap SinghDesktop Applications Specialist

Commented:
You can have less resolution than the current size easily.

I use RoyalTS for RDP at work. You can have any size (X-Y) in it.
Nagendra Pratap SinghDesktop Applications Specialist

Commented:
Does this help?

http://superuser.com/questions/138140/change-the-default-resolution-of-remote-desktop-connection-mstsc

Seems to be your case

===========================
I personally work on a 1440x900 laptop screen and like my Remote Desktop windows to be a bit smaller than the screen when maximised so I run mstsc.exe switches /v: and /w: to set its height and width (see mstsc.exe /? for a full list). mstsc.exe /h:900 /w:1100 sets it to my preferred size, and it seems to keep this setting for future sessions.
================================

Author

Commented:
Hello everybody,

I tried RoyalTS but I couldn't achieve what I wanted with it.

What I want is to have a maximized full screen 1024-768 resolution in my RDP session without changing my laptop resolution of 1920-1200.
The RDP resolution has te be streched to the edges.

Regards,


Ron
Nagendra Pratap SinghDesktop Applications Specialist

Commented:
You mean that distortion of pixels is OK?

I think I have seen that solution somewhere.

Author

Commented:
Distortion is OK in this case. Larger icons and larger fonts in the Office menu's is more important.

I tried solution @npsingh123 but I still don't get the result.
Nagendra Pratap SinghDesktop Applications Specialist

Commented:
Ok. try this.

Use VNC for now. VNC supports stretching.

Author

Commented:
You are right that VNC does the job. But VNC is for remote management and I want this problem solved for RDS users.

There must be anoher way. I can't believe I am the only one with this problem.
Nagendra Pratap SinghDesktop Applications Specialist

Commented:
This has smartsize

http://remotedesktopmanager.com/remotedesktopmanager/Home/ChangeHistory and even mstsc support smartize but you need to add a line in .rdp file

smart sizing:i:1

Author

Commented:
I don't understand why my mstsc doesn't do smartsize. I added the line.

This is the RDP I use:

screen mode id:i:2
use multimon:i:0
desktopwidth:i:1024
desktopheight:i:768
session bpp:i:32
winposstr:s:0,1,59,76,1597,1033
smart sizing:i:1
compression:i:1
keyboardhook:i:2
audiocapturemode:i:0
videoplaybackmode:i:1
connection type:i:2
displayconnectionbar:i:1
disable wallpaper:i:1
allow font smoothing:i:0
allow desktop composition:i:1
disable full window drag:i:1
disable menu anims:i:1
disable themes:i:0
disable cursor setting:i:0
bitmapcachepersistenable:i:1
full address:s:ts01
audiomode:i:1
redirectprinters:i:1
redirectcomports:i:0
redirectsmartcards:i:1
redirectclipboard:i:1
redirectposdevices:i:0
redirectdirectx:i:1
autoreconnection enabled:i:1
authentication level:i:2
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
alternate shell:s:
shell working directory:s:
gatewayhostname:s:
gatewayusagemethod:i:4
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0
promptcredentialonce:i:1
use redirection server name:i:0
drivestoredirect:s:
Nagendra Pratap SinghDesktop Applications Specialist

Commented:
OK.

Do you have a test server?


Try web desktop connection

Remote Desktop Web Connection

http://support.microsoft.com/kb/284931

I will locate my rdp file if I can. I used to control my Big desktop (1280X1024) from a laptop in the next room (1280x800) . Because I ran VMware workstation on the Big Desktop, I had to do something that the VM screens were not too small to show all options/buttons etc. Worked OK for me.
Commented:
I'm beginning to think there is no solution for this problem.
I'm closing my question.

Author

Commented:
No solution

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial