Dell M6600 + StarTech.com USB 3 Hard Disk Dock Recognition Problem

robinadair
robinadair used Ask the Experts™
on
I have a Dell M6600 running window 7 Pro x64 that has 2 x USB 3 ports.  M6600 has latest BIOS A09 and drivers per Dell support site.  However a StarTech USB 3 Hard Disk Dock (SATDOCK22U3S) is not recognised by the M6600 (OK on USB 2 and on another system with USB 3 ports so the device is functional).

Dell support have not been particularly helpful by repeating continuously that this is a third party product and USB 3 is very new and as long as a USB mouse works on the port then the StarTeck must be the problem, etc, etc.  They also suggested that I should see if StarTech had any updated drivers for the HDD!!!!!!!!!!!!!!

Anyone have any experience with this kit?

All suggestions welcome.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Afraid so, what Dell is telling you is probably correct.  Reach out to Startech.
I built a new computer hoping to avoid that issue, but my USB3 didn't even work until I updated driver three times.
that is what happens to explorers, they get lost.  :)

Commented:
Firstly,
I'd try another USB 3 device on both ports (if possible) to eliminate hardware issues,

I'd re-install the USB 3 drivers, also make sure the chip set drivers etc on your machine are up to date.

This does sound like a software issue,

Author

Commented:
Thanks for your quick reply.

I have already e-mailed StarTech but about compatibilty only.  HDD (all the one's I have encountered anyway) use Windows 7 native drivers and I have tried all the drivers for the USB 3 controller from Renesas from the Dell approved version to the latest available from Renesas - the USB 3 controller is an NEC/Renesas one but without success.

Thanks again.
Build an E-Commerce Site with Angular 5

Learn how to build an E-Commerce site with Angular 5, a JavaScript framework used by developers to build web, desktop, and mobile applications.

Author

Commented:
Hello ZeelSol

Thanks for your reply.

I have done all that and yes the Chipset is the latest.

Commented:
My issue was with a PCI card to connect a 20 pin header to my Antec case and it used a Renesas driver.  I ended up trashing that card after several driver updates from manufacturer and buying a new card.
I feel your pain, hang in there perhaps Startec will come through
Top Expert 2012

Commented:
The device worked ok with USB 3.0 on another machine, so this leaves the problem with the Dell M6600.  Everything points to the USB 3.0 implementation or the drivers.  Here's a post that lists the same problem, but the driver for a possible fix seems to be gone: http://www.sevenforums.com/drivers/183324-usb-3-0-renesas-drivers.html

Intel's site has the latest driver: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3334&DwnldID=19880&ProductFamily=Desktop+Boards&ProductLine=Intel%C2%AE+6+Series+Chipset+Boards&ProductProduct=Intel%C2%AE+Desktop+Board+DZ68DB&lang=eng
Thanks to everyone who responded but we don't appear to have reached any solid conclusion.  That goes for both Dell and StarTech!  So regretfully, I shall stick with USB 2.

Author

Commented:
Problem remains unresolved and looks unlikely to be resolved.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial