AIX - User can't create directory in their own home profile

AIX25
AIX25 used Ask the Experts™
on
User can't create a directory under home directory. NIS account.

Here is some outputs below to help out figure what the issue is....

root@nismaster[/]# su - user1
nismaster:/home/user1> mkdir test_dir
mkdir: 0653-358 Cannot create test_dir.
test_dir: Cannot exceed the user or group quota.

root@nismaster[/]# su - user1
nismaster:/home/user1> df .
Filesystem    512-blocks      Free %Used    Iused %Iused Mounted on
nisclient:/home/vg02/user1 134217728  88103128   35%   187475     2% /home/user1

nisclient:/home/user1> df -g |grep user1
/home/vg02/user1     64.00     42.01   35%   187474     2% /home/user1
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Most Valuable Expert 2013
Top Expert 2013
Commented:
Looks as if there is a quota on /home/user for user1 or their group.

Have user1 issue

quotacheck -a

or issue as root

repquota -a

Since the FS in question seems to be a NFS mount, if you want to cahnge the quota setting this  must be done on the NFS server.

Use "edquota -u user1" or "edquota -g group_of_user1" to do this.

Author

Commented:
nfsserver:/> repquota -a |grep user1
user1     +-    10548    10000   150000     none       215        0        0  

Does the output above help?
Expert Spotlight: Joe Anderson (DatabaseMX)

We’ve posted a new Expert Spotlight!  Joe Anderson (DatabaseMX) has been on Experts Exchange since 2006. Learn more about this database architect, guitar aficionado, and Microsoft MVP.

Most Valuable Expert 2013
Top Expert 2013

Commented:
The third column indicates used space (blocks), the fourth is the soft limit and the next one is the hard limit.
"215 0 0" is the same for the number of files.

Since there is no defined grace period (the time where the hard limit can be used) and since the default is one week it seems that the user has exceeded the quota more than this one week ago and is no longer allowed to use more space.

If your NFS server is AIX and the FS in question is of type jfs2 use "j2edlimit" instead of "edquota" if you want to change the quota setting.

Author

Commented:
nfsserver:/>  repquota -g -a usrgrp
4050-500 usrgrp not found in /etc/filesystems.
nfsserver:/>

nfsserver:/> repquota -g -a |grep usrgrp
nfsserver:/>
Most Valuable Expert 2013
Top Expert 2013

Commented:
OK, no group quotas enabled.

Please read my last comment again!

I had to modify it a bit because I didn't realize that there was no grace period!

Author

Commented:
I'm a bit confused. Can you sum up what you are wanting me to try and what seems to be the issue?
Most Valuable Expert 2013
Top Expert 2013
Commented:
The user has exceeded the quota.

The soft limit is 10000 blocks. Within the default grace period of one week the user has reached 10548 blocks (which is more than the soft limit).

The grace period is the time during which the soft limit can be exceeded up to the hard limit.

Now this one (default) week must have passed, and after it has passed the soft limit becomes the hard limit.

If you want to raise the quota (can't user1 clean up things instead?) you must know of which OS type your NFS server is.

If it's AIX, and if the exported filesystem is of type jfs2 use "j2edlimit" to make changes.

But according to the output of "repquota" I rather assume that it's either a Linux server or an older AIX server running standard jfs. In this case use "edquota -u user1". An editor will open where you can set new limits.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial