routed port

biggynet
biggynet used Ask the Experts™
on
I am a bit confused about the intervlan routing and routed port.

Catalyst 500 (fa0/20) <-- trunk --> (fa0/10) 3560 (fa0/24) <--> (port 1) Cisco appliance

As you can see from the description above, I have a Catalyst 3560 switch and I have port fa0/24 configured as access port vlan 50. I also have an svi configure for vlan50 as 10.1.1.1/24. fa0/24 is connected to an appliance port 1 (10.1.1.2/24).
- is fa0/24 a routed port?
- What does it take to make fa0/10 to be a routed port?

Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2012

Commented:
Check the config, if the switch is performing routing you will see the command(s)

ip routing

If you see this command your switch is configured to route traffic...
If you need post a sanatized config from your switch so we can see things more clearly...
You'll need the IP Services feature set.  Once you have this, you can configure a Layer 3 switch port as a routed port with the following commands.

conf t
ip routing
!
int fa0/10
no switchport
ip address 10.1.1.1 255.255.255.0

Open in new window

It looks like you have fa0/24 configured as an access port and not a routed port.  An access port looks like this.

conf t
int fa0/24
switchport mode access
switchport access vlan 50

Open in new window

Author

Commented:
On the 3560, there is ip routing. So to make the fa0/10 a routed port, I need to change it to an access port and assign vlan50 to it. Correct?
The fa0/20 on the Catalyst 500 has to be configured as access port with a vlan50 as well. Correct?
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Top Expert 2012

Commented:
No, read @yelbaglf comment to set ports as routed ports...

Author

Commented:
I have:
int fa0/24
switchport mode access
switchport access vlan 50
...
interface vlan 50
ip address 10.1.1.1 255.255.255.0

That's not a routed port then?
No, fa0/24 is an access port, and then you have vlan 50 set up as a routed vlan interface.
Top Expert 2012
Commented:
No you need

int fa0/24
no switchport
ip address 10.1.1.1 255.255.255.0

What your config is doing is setting fa0/24 as an access port and you are using a vlan(vlan50) to use an ip address, this will technically do the same thing but your fa0/24 is still not a routed port

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial