Avatar of sikyala
sikyala
Flag for United States of America asked on

how do get oracle agent to start up

I have a database 10.2.0.5 and I installed Oracle agent so that I could manage the database from the EM Grid control server. Then I created a database and made sure configure the database with Enterprise Manager was checked and use Grid Control for Database management was selected. It created the database successfully. I checked the agent and it wasn't started so I tried to start it. it appeared to be starting the agent then I got the following message: Starting agent ................................. failed.

There were no error messages and no log mentioned. So I don't know how to troubleshoot this. Does anyone know what could be wrong and how I can fix it?
Oracle DatabaseUnix OS

Avatar of undefined
Last Comment
slightwv (䄆 Netminder)

8/22/2022 - Mon
slightwv (䄆 Netminder)

For Oracle there is always a log.

Check under: agent10g/sysman/log

You can also try starting it from a command prompt:
emctl start agent

This should provide additional information.

>>I have a database 10.2.0.5 and I installed Oracle agent

Did you install a different agent before you created the database and told it to use Grid Control?
sikyala

ASKER
I installed the agent then I created the database the agent is 10.2.0.3 version  

there is a trace file that has entries like
2012-05-23 19:47:34 Thread-45 ERROR pingManager: nmepm_pingReposURL: Did not receive a response header from repository

THe emctl.log has entries like
28557 :: Mon May 21 16:03:19 2012::AgentStatus.pm:Processing reload
28557 :: Mon May 21 16:03:19 2012::AgentStatus.pm:emdctl status agent returned  3
28557 :: Mon May 21 16:03:26 2012::AgentStatus.pm: emdctl reload returned with exit code 0
28610 :: Mon May 21 16:03:30 2012::AgentStatus.pm:Processing reload
28610 :: Mon May 21 16:03:31 2012::AgentStatus.pm:emdctl status agent returned  3
28610 :: Mon May 21 16:03:38 2012::AgentStatus.pm: emdctl reload returned with exit code 0
562 :: Wed May 23 19:41:56 2012::AgentLifeCycle.pm: Processing start agent
562 :: Wed May 23 19:41:57 2012::AgentLifeCycle.pm:status agent returned with retCode=1
562 :: Wed May 23 19:42:05 2012::AgentLifeCycle.pm: Exited loop with retCode=3

I don't understand this info
slightwv (䄆 Netminder)

What version is the database?

>>Did not receive a response header from repository

Any other errors?
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
sikyala

ASKER
database is 10.2.0.5
ASKER CERTIFIED SOLUTION
slightwv (䄆 Netminder)

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
sikyala

ASKER
i think that is the problem when I check the agent status or try to start the agent the header looks like this

Oracle Enterprise Manager 10g Database Control Release 10.2.0.5.0
Copyright (c) 1996, 2010 Oracle Corporation.  All rights reserved.
---------------------------------------------------------------
Agent is Not Running


when I execute runInstaller and check installed products it shows agent installed version 10.2.0.3

I have a variable AGENT_HOME and it is pointing to the directory where the agent is installed and I also have the agent_home/bin directory in the path variable

My Oracle_home is pointing to the oracle database
slightwv (䄆 Netminder)

Have you tried using the 10.2.0.5 agent?  For grins I would uninstall everything 10.2.0.3 and stay with 10.2.0.5.

I've never used Grid Control outside of class but going from memory, the 10.2.0.5 agent should know how to talk to a 10.2.0.3 Grid install.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
sikyala

ASKER
ironically now it is pointing to the right emctl and the agent has started. but now it shows the upload manager as disabled and the grid control doesn't show the database server. It is suppose to see it automatically but it doesn't
slightwv (䄆 Netminder)

It has been many years since I messed with Grid Control.

Can you not go into Grid Control and 'Discover' the node?
sikyala

ASKER
I tried i keep getting response that grid automatically sees or discovers host
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
sikyala

ASKER
I found this website that suggested removing a lot of files

http://www.oracleangels.com/2011/07/disabled-by-upload-manager-emctl-status.html

then I went to the grid website and now I see the server
sikyala

ASKER
thanks for your server
sikyala

ASKER
sorry thanks for your help
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
slightwv (䄆 Netminder)

Glad to help, even though you more or less fixed it yourself...