Avatar of brucie64
brucie64
Flag for United Kingdom of Great Britain and Northern Ireland asked on

Can't find .NK2 file

System Info - Outlook 2010 running on Windows XP SP3, Exchange 2003 Email

Issue - I cannot find the .NK2 file.  I am trying to copy the end users cached email addresses to another computer.  I went in to %appdata%\Microsoft\Outlook and there was no .nk2 file.  I then made sure I was able to view hidden and system files by going in to
Tool>Folder Options>View but still not .NK2 file.  I did a search on *.NK2 but only found very old .NK2 files from old profiles.

Any help would be greatly appreciated.

Thank you in advance
Windows XPOutlook

Avatar of undefined
Last Comment
brucie64

8/22/2022 - Mon
Sudeep Sharma

Try the article below from MS to import the addresses.

How to import .nk2 files into Outlook 2010
http://support.microsoft.com/kb/980542
apache09

You cant find it because Outlook 2010 did away with using NK2 Files.

OUtlook 2010 now uses a Dat File Called Stream_Autocomplete

Its located in \Users\%username%\AppData\Local\Microsoft\Outlook\RoamCache

Here is a good ref site on copying the Data File

http://benosullivan.co.uk/windows/how-to-copy-auto-complete-in-outlook-2010/
brucie64

ASKER
Update - I am trying to export the cache email addresses from Outlook 2010 on a windows XP SP3 machine to Outlook 2010 on a Windows 7 machine.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
ctssteve

If you are unable to locate the client's NK2 file you can always create a email, make sure you have Outlook in "Offline", highlight all of his contacts in the "To" field and sent it off, it will be stuck in the "Outbox" delete it and "Work online" again and all the contacts will show up when they start to type a name.
ASKER CERTIFIED SOLUTION
apache09

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
brucie64

ASKER
Found these instructions which were able to fix my problem.

For Outlook 2010
       • You will need to move the "Stream_Autocomplete_*.dat" file. It is located in:
Win Vista and Win 7: "C:\Users\username\AppData\Local\Microsoft\Outlook\RoamCache"
Windows XP: C:\Documents and Settings\username\Local Settings\Application Data\Microsoft\Outlook\RoamCache

1. Start with you new install of Outlook on a new computer and send an email to someone by manually typing in the email address and clicking send.

2. Now close Outlook and go to to the above folder. You should see your "Stream_Autocomplete_*.dat" with a bunch of numbers before the ".dat"

3. Now find the newest (largest) corresponding file on your OLD system and copy it to the RoamCache folder on your NEW computer.

4. Lastly, rename the file from #3 to the same name as the file in #2 (rename the #2 file first).

5. Close Outlook and re-open. That should fix your issue.
brucie64

ASKER
Thank you
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.