Cannot add network printers

MaltusW used Ask the Experts™
Hi all,
The problem that I am having is that some users cannot add printers from the print server.  We have a printer server, Windows 2003 32 bit.  The error message is:

"a policy is in effect on your computer that prevents you from connecting to this print queue"

Some users have no issue, while others cannot.  Also, for the affected users, they cannot install any of the printers except for two old HP 4100 queues.  It doesn't matter what machine they are on either.  

Here is the results of another test: When I log in as the local admin, and then connect to the print server (I have to log back in the network as the user so the computer can see the printers) I can install the printer.  Then I log out and log back into the PC as the user and the user can now add those specific printers I added when logged into as admin.  But no others.  

All computers, printers, etc are in one domain.  The client machines are Windows XP 32 bit.  

Also, there are no Point and Print restrictions that I am aware of.  

Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
There probably was a GPO added after those two HP 4100 queue's wee in place. the GPO probably stops all new queues from being added but excludes certain accounts based on specific criteria.

I would review all GPO's first.
We ran into this same issue with Point and Print Restrictions being "Not Configured"

We had to disable the Point and Print Restrictions policy in the local GP.

Some users had no issues and some did. We just disabled it on a case by case basis since not every user was having this issue. Probably not the prettiest solution but it worked.


Well, I think I figured out the issue but not the solution.  Long story short, the users cannot install any new drivers from the print server.  The test I did was this: I had a look at the drivers installed on the client PC and there was a Colour Laserjet 5550 PCL 5c.  So I made a test queue on the server using that same driver, and when I tried to install it on the client machine as the regular user there was no issues.  So, now I have to figure out why.  The only problem is, I don't have exclusive rights to all the GPO's as I work in a regional office and the people in "HQ" also have a bunch of GPO's that I can't see.  

What would I be looking for in the GPO?  What has to be enabled to allow users to install print driver?


Well, I found the solution as weird as this seems.  The print server was registered with the DNS server.  I'm not sure why, but that is another question.  The funny thing is, when I did a nslookup of the server IP, it did see it.  Whatever.  


Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial