Can't communicate between servers

georgedschneider
georgedschneider used Ask the Experts™
on
I have a strange situation where i can't communicate or ping between 2 specific servers.  The servers are phbkupexec1 and phbkupexec2.  Both of the servers can communicate with any other server on the network except each other.  I can communicate from my laptop and workstation with both of the servers which is on the same subnet and remote to the servers.  Both servers are on the same subnet.  DNS is resolving correctly.  I tried moving the nic connections to differnet ports on the switch for these servers, changing Ip addrsses all with the same result.  Any idea on this issue?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Maybe a firewall rule between the two servers? Try disabling AV.

Configure a firewall rule on the servers permitting ICMP Echo Requests both inbound and outbound.

Also check DNS management for incorrect A records and aliases.

Author

Commented:
Dns is good.  No av installed. No firewall between these servers.
Any crazy IPSec policies configured?
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Not that I can see.  These are pretty recently deployed backup exec servers.  phbkupexec2 was built about a week ago.
Can you ping one server from the other and do a netstat -a at the same time on the receiving server to see if you see a connection attempt? Have you tried (silly question) pinging via the IP instead of name?
If you have pointers, try a reverse ping just to make sure there is nothing weird going on with DNS.

ping -a X.X.X.X
Sr. Analyst - System Administrator
Commented:
Hi,

Check with the network team, were any VLAN configured for the server's port in switch?

i beleive this could be the issue for this scenario...

Regards,
Prem

Commented:
Have a look at the output from the command "arp -a", to see if the servers have each others ARP records.

You can also install and run Wireshark on the server, in order to check if any of the servers receives the ICMP packet from the other server - so you can figure out which of the two servers have a problem.

I assume there is nothing fishy configured on the switch - like a private VLAN, or someting like that.

Author

Commented:
I had one of the ports in a different vlan form the others.  As soon as I changed the vlan access on the switch the issue was resolved.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial