Avatar of James Parsons
James Parsons
Flag for Canada asked on

Connect Through Remote Desktop Externally

I've forwarded port 3389 to the IP. I can RDP into the IP internally, but not externally using the external IP address. Comes up with an error: Remote desktop can't connect to the computer. Remote desktop may be disabled or the computer may be off.

As I said I can RDP into it from within the network no problem. There is an SBS 2003 server that is doing DHCP. The router / firewall is a CISCO RVS2000.
Windows NetworkingNetworking Hardware-OtherMicrosoft Legacy OS

Avatar of undefined
Last Comment
James Parsons

8/22/2022 - Mon
motnahp00

It doesn't sound like your firewall is properly configured with the port forwarding rule.
James Parsons

ASKER
I've configured the port forwarding in the 'Port Fowarding' Section for TCP and UDP ports 3389 to point to internal IP 192.168.10.200 (IP of the computer we want to connect to).
ASKER CERTIFIED SOLUTION
amenezes0617

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
James Parsons

ASKER
From inside the network I just connect to the internet IP from the RDP tool. I launch it through mstsc through run.  When  I try it from outside with the IP and port (xxx.xxx.xxx.xxx:3389) i get the same result. Inside however it works.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
James Parsons

ASKER
Works on the inside. Must be the router. I'm currently updating the firmware. Anything else it could be?
amenezes0617

I'm sorry, I mistyped the port. 3389 is the default. I don't think so, unless you have some weird firewall rule. Which OS are you running on the machine?
motnahp00

@amenezes "the default port 389"

The default port for RDP is 3389.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
James Parsons

ASKER
Yeah I knew what you meant. I tried 3389. Works inside but not outside. It's running XP Pro.
amenezes0617

I would check the windows firewall just in case, make sure it's turned off all the way. I still think it's probably your router/firewall, but there's always a change it's the windows firewall too. From the outside you can also try a telnet xxx.xxx.xxx.xxx 3389 to see if it answers.
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
James Parsons

ASKER
@bedind I'm wondering if you have a point about the default route back to the internet on the server. Are you referring to the server that hands out the DHCP addresses, or the computer that we're trying to connect to through RDP? It has a static IP set on it.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
amenezes0617

Can you get to the internet from the machine that you're trying to connec to?
James Parsons

ASKER
yes
James Parsons

ASKER
I wonder if the router is pooched
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
James Parsons

ASKER
I'm not able to telnet to the IP on port 3389 or any port. I've re-added the rule, updated the firmware and rebooted the router. Strange...
amenezes0617

Yeah, then your firewall is blocking it. Is your rule limiting the "from" range? If so, try opening it up to everyone just to test. As in from "any". I am not recommending you leave it like that, just as a troubleshooting step.
jsdray

thought of a third-party app like TeamViewer?  TeamViewer
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
James Parsons

ASKER
Here's a screenshot of the port forwarding rule.
PortForwarding.JPG
amenezes0617

Looks pretty straight forward to me, the only thing I can think of is that if in one of those "Applications" drop down they offer a built in one for terminal services, or soemthing like that that you could try.
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
amenezes0617

Do you have another machine iwth that IP maybe? THat is strange...
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
XorgeD

Hi,

When you are trying the RD from the outside you are using the PUBLIC IP, right?

If you are only opening and forwarding ports on you router, you should be able to connect from the outside using the public IP.

Hope this helps
amenezes0617

That is a great point, sometimes we assume the most obvious points...I think he got it working though.
James Parsons

ASKER
I changed the static IP on the machine and it worked - could have been a duplicate IP I suppose.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23