Server 2008 stuck rebooting stop: c00002e2

mrbayIt
mrbayIt used Ask the Experts™
on
Hi all, we have a failed domain controller. Its rather old, poweredge 830, with raid 5 on cerc sata 6 channel controller, but its running server 2008. Its failing and boot looping, when i disable automatic restart error message is,

 -c00002e2 Directory Services could not start because of the following error:

-A device attached to the system is not functioning.

-Error Status: 0x0000001.

I've verified the raid is fine, running in optimal state, i also can boot into Dsrm, ran check disk and everything but cant seem to figure out the problem. Theres nothing plugged into it, so i cant see what attached device is attached to the system. The worse part is we're a school, and we don't have any backups. I've looked at other solutions on here, but none of them work and there problems aren't similar to mine. Any help would be tremendously appreciated,
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
Im afraid i saw all of these articles, but they arent specific to me because im not on a hyper v solution, just a straight server with raid array. I dont have any backups, and i tried the activate instance to rebuild ntds file, which worked, but it still wont start.

Commented:
can you boot in directory services restore mode?

- if yes, can you check the date/time
- can you check for other issues in the eventvwr
- have any patches been installed prior to the issue happening?
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Author

Commented:
yes, im actually logged into dsrm mode now. and time and date looks good. Event log is full of red flags, one thing i have just noticed since your message. I had yellow bangs in device manager hidden devices.
-link layer topology mapper
-link layer topology responder
-security processor loader driver

I've since uninstalled the link layer drivers, and when i do scan hardware changes it doesn't refind it, however after reboot even though i uninstalled security processor loader driver and it went away but when i rebooted and it bsod and i went back into dsrm the problem came back and its yellow bang.
I have the same problem on a fresh SBS 2008 install, rebooted after some drivers and updates to the bluescreen.

Commented:
according to http://www.sevenforums.com/hardware-devices/91275-security-processor-loader-driver.html
the Security Processor Loader Driver is related with the graphics driver

the other seem network related, can you try to uninstall the network driver (and reinstall after boot)

did you also run a SFC /scannow yet?
Commented:
problem ended up being a corrupt ntds database, for which it could not replicate wiith the rest of the dc's

Author

Commented:
had to reseearch it myself, knowone was able to find out the problem which ended up being what i listed

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial