Avatar of mikey250
mikey250
 asked on

3600 router - reboots round in circles

hi i accidentally deleted my 'ios' so not even sure if i had an indentical copy so i was forced to try and copy another 3640 type ios as i have a selection:

my router is a 3600 series with 4 serial & 2 fastethernet port.  i have various 3640 ios types but when i use one of these versions it appears to copy as normal via my tftp/xmodem set as 115200, but then states: erasing flash....032x0000 - hex changes intermitantly

as a result of deleting accidentally my 'ios' i was taken to 'rommon mode'

so i followed instructions:  

http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008015bfac.shtml#proc_3600

- i got as far as step 4 but eventually my router now just reboots round in circles, so ive obviously selected something for this to happen. not sure what

- ive noticed it states - "wrong system software for this hardware"

i then wait for a long period of time and it reverted back to: rommon mode

when i reboot the router or do: ctrl/alt/break etc it appears to just hang, so not sure if i should just leave it and just wait...!!!

question.  can anyone help ?
Routers

Avatar of undefined
Last Comment
mikey250

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Matt V

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
mikey250

ASKER
System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by cisco Systems, Inc.
oC3600 processor with 65536 Kbytes of main memory
Main memory is configured to 32 bit mode with parity disabled

program load complete, entry point: 0x80008000, size: 0xa5eb20
Self decompressing the image : ################################################################################################################################################################################################################################################################################################################################################################################################## [OK]


Smart Init is enabled
smart init is sizing iomem
  ID            MEMORY_REQ                 TYPE
000024          0X00019A40 Four port Async/Sync
0000D8          0X00178610 Dual Fast Ethernet Combo Port Module, 2 WAN
                0X000F3BB0 public buffer pools
                0X00211000 public particle pools
TOTAL:          0X00496C00

If any of the above Memory Requirements are
"UNKNOWN", you may be using an unsupported
configuration or there is a software problem and
system operation may be compromised.
Rounded IOMEM up to: 5Mb.
Using 7 percent iomem. [5Mb/64Mb]


Wrong system software for this hardware

System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by cisco Systems, Inc.
oC3600 processor with 65536 Kbytes of main memory
Main memory is configured to 32 bit mode with parity disabled

program load complete, entry point: 0x80008000, size: 0xa5eb20
Self decompressing the image : ###################################################################################################################################################################################################################################################################################################################################### [OK]


Smart Init is enabled
smart init is sizing iomem
  ID            MEMORY_REQ                 TYPE
000024          0X00019A40 Four port Async/Sync
0000D8          0X00178610 Dual Fast Ethernet Combo Port Module, 2 WAN
                0X000F3BB0 public buffer pools
                0X00211000 public particle pools
TOTAL:          0X00496C00

If any of the above Memory Requirements are
"UNKNOWN", you may be using an unsupported
configuration or there is a software problem and
system operation may be compromised.
Rounded IOMEM up to: 5Mb.
Using 7 percent iomem. [5Mb/64Mb]


Wrong system software for this hardware

System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by cisco Systems, Inc.
oC3600 processor with 65536 Kbytes of main memory
Main memory is configured to 32 bit mode with parity disabled

program load complete, entry point: 0x80008000, size: 0xa5eb20
Self decompressing the image : ################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################### [OK]
Matt V

mikey250

ASKER
this is the 'ios' - c3640-is-mz.122-5.bin

im not sure if i saved a backup copy of the original 'ios' although i have others.

that 'url' does not show anything as appears to hang.
Your help has saved me hundreds of hours of internet surfing.
fblack61
SOLUTION
Matt V

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
mikey250

ASKER
originally when: rommon mode > was shown i did:

- confreg 0x2102
- baud rate set to 115200
- xmodem  c3640-is-mz.122-5.bin
- then in hyperterminal selected 'transfer/send file' to locate ios
- router copied flash
- reset or recycle - so i typed reset but this appeared not to work so i repeated the above and actually unplugged power cable but did not work.  this was done a few times.

i then did:
- confreg 0x2102
- baud rate set to 115200
- xmodem  -c c3640-is-mz.122-5.bin (c is for:  Optional) CRC-16 checksumming, which is more sophisticated and thorough than standard checksumming. although im not sure if needed!!!

- then in hyperterminal selected 'transfer/send file' to locate ios
- router copied flash
- erasing flash e300f00fde etc hex keeps changing
router just reboots all the time now!!!round in circles
ctrl/alt/break - appears to work but appears to hang showing

System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
oPC = 0xbfc0a024, Cause = 0x2000, Status Reg = 0x3041f003

i have selected boot configuration as:

change the boot characteristics? y/n  [n]:  y
enter to boot:
 0 = ROM Monitor - originally rommon showed as 1st step
 1 = the boot helper image - i think this was my last change so it maybe stuck here!!
 2-15 = boot system - i then selected 2 as 2nd step
    [0]: 1

i have set back router to: 9600 and hyperterminal is also set to 9600.  i have attempted to put hyperterminal baud rate to 115200, but it does appear to detect the router at all, so i returned hyperterminal back to: 9600 where i can see the router bootup.

unless i need to open up the 3600 and reset some jumper but i have never looked so im not sure but read about resetting 'baud rate' via jumpers.

however i just looked inside my 3600 and the only jumper pins i can see are 2:

a white jumper with 4 pins but no jumper on it but below it states: rev
a 3 pronged jumper with a jumper on 2 of the pins and below it states: duart_rst

these are the 'ios' i have but im not even sure which one is the most upto date or how to even choose a specific ios for specific task as i assume customers dont wont extra features if they are not going to be used or maybe even used by a hacker, although not sure about the hacker part. uuuummmmmmm

c3620-ik9o3s6-mz.123-9.bin
c3620-j1s3-mz.123-21.bin
c3640-ik9o3s-mz.124-3.bin
c3640-io3-mz.123-1a.bin
c3640-is-mz.122-5.bin
c3640-is-mz.123-1a.bin
c3640-jk9o3s-mz.123-8.T3.bin
c3640-jk9o3s-mz.124-5a.bin
c3640-jk9s-mz.123-2.T.bin
c3640-js-mz.122-8.T.bin
c3640-js-mz.123-6a.bin
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mikey250

ASKER
hi yes i realise this! but as i could not come out of 'rommon mode' i tried anything and messed it up :(((
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mikey250

ASKER
morning, yes i know i get this:

ctrl/alt/break - appears to work but appears to hang showing

System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
oPC = 0xbfc0a024, Cause = 0x2000, Status Reg = 0x3041f003

i may need to leave it for alot longer !!!!!!!!!!!!!!uuummm
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mikey250

ASKER
hi yes i did prior to issue see 'rommon' but now it is unsuccessfully probably because of my passed intervention on previous thread explanations.

my keyboard is standard as usual as used 'cltrl/break' before and works successful before.

previous - yes i did do the following:

rommon 1 >confreg 0x2142

and use the reset key to save your new config.

rommon 1 >confreg 0x2102

and use the reset key to save your new config.

 rommon 1 >reset - same issue as above - prior

 rommon 1 >reset - router just hung so i unplugged but now after making changes to 'boot- ie pointing to 'ios help' it now reboots in circles.

so now i get as below:

ctrl/break - appears to work but appears to hang showing

System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
oPC = 0xbfc0a024, Cause = 0x2000, Status Reg = 0x3041f003
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mikey250

ASKER
hi, my config should already be deleted but that is ok as wish to start a fresh!!!  as for default settings, ive opened up the 3600 case and saw the following:

white jumper - with 4 pins but no jumper on it but below it states: rev
a 3 pronged jumper with a jumper on 2 of the pins and below it states: duart_rst - so i moved across and rebooted my router but this did not appear to do anything except the router still reboot in circles.
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mikey250

ASKER
hi i forgot to mention, yes i have a cisco account but only 'basic', so im not sure if the 'chat' will work but will try tomorrow!!!! :((((((((
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
mikey250

ASKER
hi i dont know why but my router has now returned back to 'rommon' as the router just hung previously.

i can type commands in and ive selected a specific 'ios', to be copied via 'xmodem', but for some reason after successful completion i then type:

- reset - system appears not to respond so i cannot then follow the next instruction to change to '0x2102' - uuuuuuuuuuummm
koudry

Hello,

Is this case still open? Have you contacted Cisco yet?
mikey250

ASKER
hi ive only got a basic account with 'cisco' but i have asked the question but no reply yet!
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mikey250

ASKER
hi koudry, i have not forgotten about this thread but still wanted to come back as last time i carried out the advice my router did get back to 'rommon mode' but i was still not able to break out of it and as i only have a cisco guest account i could not take it any further!!  the router is to one side at the moment but i wish to plug back in sometime soon and have another go!!!
mikey250

ASKER
hi koudry, i will be returning to this thread as ive attempted to try and resolve this issue with my router but it did not work with extra reading on google but now my router when switched on appears now to just hang showing no response via hyperterminal unless i press the keyboard and see some random characters!!

im thinking im might have changed the baud rate or something but cannot seem to get it right!
mikey250

ASKER
hi koundry, just so you know ive now repeated those steps to stop 'rommon' from still appearing and for some reason it has now dissappeared and i can now use the router!!

apologies for taking so long to close this thread!!
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
mikey250

ASKER
it could well be one of my steps i might have not input correctly or missed out as for some reason my router is no longer is rommon mode.  sound advice!

appreciated!!!