Link to home
Start Free TrialLog in
Avatar of trims30
trims30

asked on

Crystal Reports in VB.Net

Am struggling to learn Crystal Reports and have two stumbling blocks at the moment that I need some help resolving.

Computer is Win7 64 with VS2008
Database is MsAccess

Have added CrystalReportiewer to my form, used the Wizard to connect to database and select my tables.  Have been able to design a simple report and view it in Main Report Preview mode.

When I attempt to run the report I get error :
"Failed to load Database information Details: The database DLL ‘crdb_doa.dll’ could not be loaded. "

Have tried setting my project to build for X86 processor with no improvement.
How do I get this issue resolved?

Next issue is - how do I set page layout so I can design in Portrait?  I can't find that setting

help is appreciated.
Avatar of Mike McCracken
Mike McCracken

In the full versions  Portrait - FILE --> PAGE SETUP

What version of Crystal?
What framework of .Net?
What version of MS Access?

mlmcc
Avatar of trims30

ASKER

Am using Crystal that's included with VS2008 (CrystalReportViewer toolbox item)
Access is  2007
.Net Framework 3.5

Finally Found the page setup and was able to make that change
ASKER CERTIFIED SOLUTION
Avatar of Nasir Razzaq
Nasir Razzaq
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of trims30

ASKER

Access/Excel DAO is how I'm connecting to my MDB file
What other drivers do you see in the list?
Do you have the latest service pack for VS2008 Crystal?
I believe you need it to be 64-bit compatible.

mlmcc
Avatar of trims30

ASKER

Evidently Access/Excel DAO not compatible with Win7 64.
Tried making VB.Net run as 32 bit x86 but still same problem

CodeCruiser - I saw that blog before I posted question - same problem I'm experiencing.

looked further at Build properties and was able to change to x86 and it works now.

Thanks