VM external USB sound card

NetRock6
NetRock6 used Ask the Experts™
on
I am trying to get output from external usb soundcard in VMWare workstation 7. it is attached to my guest windows7 but there is no sound output. Drivers are installed for the external USB soundcard. Is there more steps to configure.

Thanks for your help
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
is the virtal machine in the settings usb can be set
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
have you successfull connected to the Guest VM, did it plug and play and install drivers?

also remember that not ALL USB devices are supported!

Author

Commented:
Yes. it is successfully connected to the Guest VM, and set as default device for communication. Everything looks good as far as i see.
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
drivers installed?

Commented:
is it in the control panel /device manager / sound as a device with no yellow checkmark ?

Author

Commented:
No Yellow Check Marks.. It is installed correctly. I was wondering if the device has an issue!!
Tried out on physical PC and no sound!! i will try on different PCs.

Author

Commented:
I have "Buffer Full" error, once i connect the USB device to guest PC. is there a way to expand the buffer size of the USB in the guest PC.
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
I believe this was fixed in late versions of workstation 7.1.5, or was an issue with web cam devices

Author

Commented:
Sorry, i get error: "Audio Buffer Full" . so i need to change the size of the Audio Buffer not USB. In Physical PC i have no issue and have a clear sound.
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
out of curiosity why are you not using emulated virtualised sound in the VM by adding virtual sound?

Author

Commented:
There is APP that uses this USB device. Cannot use the Virtual Sound.
I found this link:
http://communities.vmware.com/message/416893#416893
will try to see if that helps, till some one comes up with a better solution!!

Author

Commented:
The link did not help. But i was able to find out that the external USB device sends packet of 512kb and older model sends 1024.
With older model i can get output but with newer model, sends 512kb, i can not. it seems that i need to increase my host (VM) performance, But how can i increase the performance to handle block of 512kb packets from USB port. Basically, need more CPU power to handle the process.
Commented:
Ok. I increased the CPU and all works fine.

Author

Commented:
I increased the CPU and all works fine.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial