Email Issue -Sharepoint WSS 3.0

badabing1
badabing1 used Ask the Experts™
on
Hi ,

I have a strange issue that im unable to fix, we have migrated from exchange 2003 to exchange 2010.

I had a distribution set for recieving email from the sharepoint WSS 3.0 (no MOSS) re access request to the sites etc.. when the sharepoint was pointing to the old exchange 2003 as an smtp server, emails alerts worked as expected. Since pointing it to the new email excahnage 2010 server as an smtp its not working, (even though when user request access from sharepoint it say request send successfully).

I have checked all the settings again and again and made sure the IP of the sharepoint is listed to relay through the exchange 2010- i have even specifed my own email address in the reply to address in sharepoint under outgoing e-mail settings to no avail?

Whats going on and how can i fix this?

p.s - Another strange thing is that alerts set in document library etc are working fine, using the very same distribution group. (we get alerts every morning of any changes)- so it looks like there is something wrong at the central administration level within the sharepoint...?

Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Most Valuable Expert 2013
Awarded 2012
Commented:
Hi,
AFAIK alerts are generated and sent through the SharePoint windows timer service, access request through the web app/IIS.

Just a guess_
If your server has multiple IP addresses, perhaps you have to configure exchange server to relay the other one as well.

HTH
Rainer

Author

Commented:
we do have multiple IP, im pointing it to the correct one thats listening...
Most Valuable Expert 2013
Awarded 2012

Commented:
Hi,

sorry I did not understand your response.

If your SharePoint server has two IPs - lets say 10.0.0.4 for the server and 10.0.1.5 for the SharePoint web application - then you should configure Exchange server to relay for 10.0.0.4 and 10.0.1.5.
As you wrote, alert emails are sent which means that the IP used from the Windows SharePoint Timer Service is allowed to send, the SharePoint IIS Web application not.
Can you enable some logging in Exchange (I am no pro in Exchange) - perhaps you can see some "Denied" events.

HTH
Rainer
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Author

Commented:
sorry for the delay reponse- i meant we have two ip for the exchange server not  the sharepoint (sharepoint has only one IP). where else can i check settings for sharepoint IIS Web application for email alerts?

Thanks

Author

Commented:
any help here please?
Justin SmithSr. System Engineer
Top Expert 2012

Commented:
You don't have unique settings for outbound email on each of your web apps, correct?  You can make the global setting in System Settings - Outbound Email.....but you can also set this per web application (which overrides global) in web application management in Central Admin.
i changed the sender email to something else from within sharepoint Central Admin, this did the trick, not sure why but its works..

Author

Commented:
ive awarded 100 points for the help i got, but rest to myself as i found a way around.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial