Setting up Cisco 2901 Router with Comcast Broadband modem

DebbieHamatani
DebbieHamatani used Ask the Experts™
on
I am trying to set-up a Cisco 2901 router that is connected to a Comcast High-Speed Modem.  The connection is live since I connected a laptop directly to the modem and the internet works.

Below is the configuration from the router:
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname Cisco2901
!
boot-start-marker
boot-end-marker

no aaa new-model
!
no ipv6 cef
no ip source-route
ip cef
!
no ip bootp server
multilink bundle-name authenticated

!
interface Embedded-Service-Engine0/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 shutdown
!
interface GigabitEthernet0/0
 description $ES_WAN$
 ip address 173.xx.yy.109 255.255.255.240
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 duplex auto
 speed auto
 no mop enabled
!
interface GigabitEthernet0/1
 description $ES_LAN$
 ip address 192.xx.yy.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 duplex auto
 speed auto
 no mop enabled
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 173.xx.yy.110
!
logging trap debugging
!
no cdp run
!
snmp-server community public RO
!
control-plane
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1

Is there something I am missing?  It tries to connect from the laptop, but just keeps looping.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2012

Commented:
Try changing this line

ip route 0.0.0.0 0.0.0.0 173.xx.yy.110

to

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0

When logged into the router can you ping any internet address?
Ping 8.8.8.8 - what does this show?
DebbieHamataniIT Specialist I

Author

Commented:
I changed the setting from the static IP address to GigabitEthernet 0/0 in the routing and this did not solve the problem.  

When pinging any address I receive host not reachable.  

According to comcast the gateway should read 173.xx.yy.110 should that the IP address of the WAN port?

Thanks
Top Expert 2012

Commented:
What should your WAN IP be? Did you ask?
If they say the gateway should be 110 this can mean multiple things, its either there side or as you mention your WAN port

Try it on your WAN and see if it helps...

 ip address 173.xx.yy.110 255.255.255.240

You currently have it set  ip address 173.xx.yy.109 255.255.255.240
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

DebbieHamataniIT Specialist I

Author

Commented:
Here is the response from Comcast:
We don’t support devices behind our gateway due to liability issues and that there are a million different devices.  If you are wanting the device set up in pass thru we you will want to put the .110 in your router and I can make the changes on the gateway.  Let me know and I can change it up.

So, I am not sure how helpful Comcast is.

I tried to put the 110 in the WAN and it still does not work.
Top Expert 2012
Commented:
Ok well 110 on WAN port as they said is correct, and you left the GigabitEthernet0/0 on the end of the route command as well yes?

There are 2 other things missing - NAT and DHCP?

I assume you are assigning static IP's to your laptop/pc you are testing with yes? What IP has your laptop at minute?

And you also need a NAT statement I think

ip nat inside source list 1 interface GigabitEthernet0/0 overload

Put this accesslist in as well

access-list 1 permit 192.xx.yy.1 0.0.0.255
you have what I presume is s public address and a private address in your config, but no NAt statement.

You need to enable NAT
DebbieHamataniIT Specialist I

Author

Commented:
It was the nat that needed configured.  Called Cisco and they walked me through it.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial