Link to home
Start Free TrialLog in
Avatar of drugstore
drugstoreFlag for United States of America

asked on

F5 doesn't pass original IPs

All,
  Big IP 3600s working perfectly for dozens of servers and load balancing is going well.  But... the only IPs that show up in web server logging belong to the pair of F5s.  I would like the F5 to pass the original IP of our customers for many reasons, namely tracking who is hitting our services.

  The setup is fairly traditional- edge router to firewall to F5 to server.  I have spoken with F5 who pointed me to this setting:
Main | Local Traffic | Virtual Servers | Profiles | Insert X-Forwarded-For

  That setting was disabled; I enabled it, applied it, and no change resulted.

  I've looked high, low, and all over the F5 web site and will have to call them again, unless you have an idea...
SOLUTION
Avatar of giltjr
giltjr
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of drugstore

ASKER

Thank you experts!  I enabled the X-Forwarded-For setting which you can see in Wireshark with the nifty display filter "http.x_forwarded_for."  Then, in the Microsoft IIS web server section of the article referenced by breadtan (SOL4816), there is an IIS ISAPI filter update to IIS Advanced Logging that allows the original IPs to be logged and viewed.