Plesk Backup errors

zack4x4
zack4x4 used Ask the Experts™
on
Hi - I'm not sure what's going on with Plesk in the backup module on an individual account.  It's running Parallels Plesk CP 8.6.0.  I tried running a backup half way through it died and it's been giving me this error ever since....

0: /usr/local/psa/admin/plib/backup/BackupRestoreCommon.php:383BackupFTPRepositoryDriver->getBackupsList()1: /usr/local/psa/admin/plib/backup/BackupRestoreCommon.php:81BackupRestoreCommon->fetchBackupsList(object of type BackupFTPRepositoryDriver)2: /usr/local/psa/admin/plib/backup/BackupRestoreCommon.php:68BackupRestoreCommon->getBackupsList()3: /usr/local/psa/admin/plib/backup/BackupFilesList.php:101BackupFilesList->fetchBackupFilesList()4: /usr/local/psa/admin/plib/class.cList.php3:103cList->fetchList()5: /usr/local/psa/admin/plib/class.cList.php3:123cList->init()6: /usr/local/psa/admin/plib/backup/BackupFront.php:99BackupFront->stepBegin()7: /usr/local/psa/admin/plib/PMM/MigrationCObject.php:102MigrationCObject->make()8: /usr/local/psa/admin/htdocs/backup/main_client.php:26require(string '/usr/local/psa/admin/htdocs/backup/main_client.php')9: /usr/local/psa/admin/htdocs/plesk.php:23

Thanks - Zack
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
I'm going to guess that as you are still running 8.6 that you don;t have support from Plesk and that you're not terribly happy with the current pricing structure.

Has anything changed with the FTP server that you are backing up to or a firewall between the FTP server and the Plesk install ?

The below worked for me last week on a Plesk 8.2.1 server that failed to backup when I was migrated a 7 year old Athon 500 with 512mb and a 60gb disk and a purchased copy of Plesk 8.2.1 that was costing $87 per month to a VPS host with 1024mb and a 50gb disk VPS that included a 10 domain licence of Plesk 10.4 for $30 per month...

Copy the old backup files out of the directory that Plesk is backing up to.

Set all backup schedules to off via the Plesk panel.

Check that there are no backups completing via the Plesk panel.

Logon to a shell on the server

Check that there are no backup processes running

 
ps -ax | grep backup

Open in new window


Login to MySQL

mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa

Open in new window


See if there are any backup listed as running

select * from BackupsRunning;

Open in new window


If there are, delete them

delete from BackupsRunning;

Open in new window


I would then try to run the backup again.

If it still fails, you could try running a command as per

./pleskbackup -v --domain <domain name> ftp://<ftpuser>:<ftp password>@<ftp server>/<path>/<filename>

Open in new window


However for two domains I ended up copying the files with rsync and manually exporting the MySQL databases, then re-creating the databases on the VPS server and importing the database exports.

Granted your environment will be different to the one that I migrated, but if you're running Plesk 8.6 I'm going to guess that you're also running on "old" hardware and you might find it cost effective to move to a new server or even virtual server. The friend that I migrated reduced his annual costs by $684...

Author

Commented:
Appreciate the feedback.  I dont own the server I'm just hosting my domain on there.  I told the admin guy I would investigate as he didn't have a clue.  Personally I hate Plesk.  It doesn't have half the features of cpanel it appears.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial