Link to home
Start Free TrialLog in
Avatar of cpatte7372
cpatte7372Flag for United Kingdom of Great Britain and Northern Ireland

asked on

How To Run ASA in GNS3 in mult

Hello Experts,

I have successfully got Cisco ASA simulated in GNS3. However, each time I try run the ASA in multiple mode I get the following error message:

ciscoasa1(config)# mode multiple
The activation key for this product does not allow security contexts
ciscoasa1(config)#

There are a few solutions on GNS3's site but they seem to suggest adding the following configuration 'When the Window Opens', but I don't know what that means.

modprobe e1000
ifconfig eth0 hw ether 00:00:AB:CD:10:10
ifconfig eth1 hw ether 00:00:AB:CD:10:11
ifconfig eth2 hw ether 00:00:AB:CD:10:12
ifconfig eth3 hw ether 00:00:AB:CD:10:13
ifconfig eth4 hw ether 00:00:AB:CD:10:14
ifconfig eth5 hw ether 00:00:AB:CD:10:15
ifconfig eth0 up
ifconfig eth1 up
ifconfig eth2 up
ifconfig eth3 up
ifconfig eth4 up
ifconfig eth5 up
cp /asa/bin/lina /mnt/disk0/lina
cp /asa/bin/lina_monitor /mnt/disk0/lina_monitor
cd /mnt/disk0
/mnt/disk0/lina_monitor

Can someone please help?

Cheers

Carlton
Avatar of cpatte7372
cpatte7372
Flag of United Kingdom of Great Britain and Northern Ireland image

ASKER

Experts,

I also found these activation keys;

Activate the licenses using below codes:

activation-key 0x4a3ec071 0x0d86fbf6 0x7cb1bc48 0x8b48b8b0 0xf317c0b5

activation-key 0xb23bcf4a 0x1c713b4f 0x7d53bcbc 0xc4f8d09c 0x0e24c6b6

Can someone tell me where to apply them?

Cheers
Experts,

I'm running GNS3 on Windows 7
ASKER CERTIFIED SOLUTION
Avatar of Shane McKeown
Shane McKeown
Flag of Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
smckeown,

It accepted them in config mode, however, unfortunately I still get the same message when trying to change the mode from single to multiple.
Where did you source the keys? Why are there 2 I'm wondering?
Did you reboot the asa after applying the keys?

Just for a test apply 1 key and reboot, if not working apply the 2nd key and reboot...
smckeown777

Yes I rebooted, but no luck.....
I think the problem might because I'm using a 'kernel' for linux and I'm running the ASA on Windows 7:

Initrd:          C:\ASA\asa.gz
Kernel:          C:\ASA\vmlinuz
Ok not sure I can assist from here, obviously this is GNS based stuff, have you confirmed from the site you obtained the keys that the versions/configs are all the same? Sorry not up to speed on GNS stuff unfortunately...
smckeown777, you got it.

I just needed to reboot twice. It works.

Thanks man.

Cheers
Cheers mate.