Public Folders in Exchange - failed to create database files

sclltd
sclltd used Ask the Experts™
on
We have an environement with 2 x DAG servers and 2 x CAS servers, this has been upgraded from Exchange 2003. We recently completed the migration of the public folders to one of the DAG servers and then removed the public folders from Exchange 2003, this is all working as expected. As a last step we wanted to create anothe public folder on our second DAG server and then replicate the public folders. We used EMC to create the public folders, this created the entry in the ‘Organisation Configuration/Mailbox’ view but did not create the actual database files. How can this issue be resolved?


Summary: 2 item(s). 1 succeeded, 1 failed.
Elapsed time: 00:00:06


New Public2
Completed

Exchange Management Shell command completed:
new-publicfolderdatabase -Server 'POES2' -Name 'Public2' -EdbFilePath 'E:\Exchange\Mailbox\Public\Public.edb' -LogFolderPath 'E:\Exchange\Mailbox\Public'

Elapsed Time: 00:00:03


Mount Public2
Failed

Error:
Couldn't mount the database that you specified. Specified database: Public2; Error code: An Active Manager operation failed. Error: The database action failed. Error: An error occurred while trying to select a database copy for possible activation. Error: The database 'Public2' was not mounted because errors occurred either while validating database copies for possible activation, or while attempting to activate another copy. Detailed error(s):


        poes2:
        An Active Manager operation failed. Error: Couldn't find the specified mailbox database with GUID 'e3dae293-4d22-4e2b-9113-fa0a8c0545b5'.. [Server: POES2.ctrak.local]
        . [Database: Public2, Server: POES1.ctrak.local].

An Active Manager operation failed. Error: The database action failed. Error: An error occurred while trying to select a database copy for possible activation. Error: The database 'Public2' was not mounted because errors occurred either while validating database copies for possible activation, or while attempting to activate another copy. Detailed error(s):


        poes2:
        An Active Manager operation failed. Error: Couldn't find the specified mailbox database with GUID 'e3dae293-4d22-4e2b-9113-fa0a8c0545b5'.. [Server: POES2.ctrak.local]
        . [Database: Public2, Server: POES1.ctrak.local]

An Active Manager operation failed. Error: An error occurred while trying to select a database copy for possible activation. Error: The database 'Public2' was not mounted because errors occurred either while validating database copies for possible activation, or while attempting to activate another copy. Detailed error(s):


        poes2:
        An Active Manager operation failed. Error: Couldn't find the specified mailbox database with GUID 'e3dae293-4d22-4e2b-9113-fa0a8c0545b5'.. [Server: POES2.ctrak.local]
        .

Exchange Management Shell command attempted:
mount-database -Identity 'Public2'

Elapsed Time: 00:00:02
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
How long after you created it did you you attempt to mount it ?

You might want to run dcdiag to check AD replication.
sclltdPre-Sales

Author

Commented:
The physical files did not get created so the database cannot be mounted.
Pre-Sales
Commented:
Found the CPU maxed out today so restarted the server, ageter the resstart I was able to mound the database which then created the database files.
sclltdPre-Sales

Author

Commented:
Resolved the issue myself after rebooting the server.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial