How to enable "Allow service to interact with desktop" in Task Scheduler

renilchalode
renilchalode used Ask the Experts™
on
Hi friends ,

Do anyone know how to enable the option "Allow service to interact with desktop" in Task Scheduler ?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Allow service to interact with desktop is available for the Service which is available on the services.msc console.

Select the service --> right click --> properties --> Logon Tab --> Select "Allow service to interact with desktop"

This option is not avaibale on schedule task.
If you want to enable "Allow service to interact with desktop" for schedule taks service.

Start --> Run --> type services.msc --> select Task Scheduler --> right click --> select properties --> Logon Tab --> Select Local system account and select "Allow service to interact with desktop".

Author

Commented:
yea...sorry..I could have made my question little more elaborative.....Those options are like faded and am not able to change it...How to enable it back ?
The only requirement I can see is it has to be run from the Local System account.
e.g.
Local System owned Service
What particular service are you trying to set to 'interact'?

Also, what version of windows, specifically, do you have?
Need to have admin priviliege to perfrom the change or it may the service setting may be applied from GPO.

To check if the service setting applied by GPO.

Start --> Run --> rsop.msc

Expand to Computer Configuration--Policies--Windows Settings--System Services and check if any GPO is applied for the schedule service.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial