Link to home
Start Free TrialLog in
Avatar of mgudites1
mgudites1Flag for United States of America

asked on

IIS 6.0 resets my certificate bindings after IISRESET

I'm trying to update certificates on a Windows 2003 server that has several IIS web sites.  My wildcard certificate, root and intermediate are all in the MMC store.  I apply it to web site, and it takes.  I go to the web site and click on the certificate info button, and I see my new cert.  

I do an IISRESET and *poof*, everything reverts back to the old certificate.  I've used this same certificate on a number of servers now, and have succesfully made it work on all the others.  WTF is going on???

FWIW:
*  Logging on as local administrator (this is not a domain server)
*  Windows Server 2003 Standard SP2
*  There's nothing related in the event viewer
Avatar of Kash
Kash
Flag of United Kingdom of Great Britain and Northern Ireland image

Avatar of mgudites1

ASKER

Deleting the old certificate doesn't sound like a good idea if this is happening.  What will I do if this new one doesn't stick, and then I don't have an old one to revert back to?  The old one is still working, it just needs to be replaced.  Besides, the fact that the old one is in the store shouldn't be a problem.

All three of the articles you posted refer to IIS 7 and 7.5. I'm on IIS 6.
ASKER CERTIFIED SOLUTION
Avatar of mgudites1
mgudites1
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
never figured it out