How to configure cisco 7206 as a E1 gateway

globotech
globotech used Ask the Experts™
on
Hello everyone,

this is a rather vague qusetion so far but I hope it will eventually become a more specific one. Here's my situation.

I'm supposed to set up a 7206 VXR router as a gateway between some ethernet traffic I'm about to receive from a provider and 5 E1 circuits from another provider. However, I have no experience whatsoever with voice lines etc. I've worked with cisco routers for a long time, I've never configured something similar though.
I have an E1 module already installed on the router, I configured the E1 controllers as unframed, but that's all I've actually done. Setting up the internet connectivity, ACLs etc is easy, what I need to know is HOW I will converd the ethernet traffic to TDM.

So, could someone fill me in on things I should know beforehand and/or post an example configuration?

Thanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
One option for the Ethernet aggregation, is to have 3 layers:

(1) The PoP switch: provides VLAN for each client, e.g. VLAN 10, 20 & 30 for client1, client2 and client 3 respectively. The switch will also configure a trunk interface to the aggregator router.   This will carry VLAN tags for each client.  Access ports will also be corrected for each client.

(2) The Aggregator: will configure a main interface or trunk to carry the sbu-interfaces.  Sub-interface for each client is also configured, each with appropriate VLAN tag and IP address.

(3) Ethernet client: will provide IP address

A sample code has been provided below - this also tested in GNS3

! switch config - using GNS3
!
hostname PoPSwitch
!

vlan database
vlan 10
vlan 20
vlan 30
exit
!
! Configure access ports
!
conf t
int f1/0
description Access port for VLAN 10 client
switchport mode access
switchport access vlan 10
no shut
!
int f1/1
description Access port for VLAN 20 client
switchport mode access
switchport access vlan 20
no shut
!
int f1/2
description Access port for VLAN 30 client
switchport mode access
switchport access vlan 30
no shut
!
! Configure Interface trunk to Aggregator
!
int f1/3
description Trunk interface to Ether agg
switchport trunk
switchport trunk allowed vlans 10,20,30
no shut
!

interface lo10
ip address 81.128.147.1 255.255.255.255
!
=================================================

Ether agg

!
hostname EthAgg
!
interface f0/0
description Main interface
speed 100
duplex full
no shut
!
interface f0/0.10
description VLAN 10 client
encapsulation dot1q 10
ip address 192.168.100.9 255.255.255.252
!
!
interface f0/0.10
description VLAN 10 client
encapsulation dot1q 10
ip address 192.168.100.9 255.255.255.252
!
!
interface f0/0.20
description VLAN 20 client
encapsulation dot1q 20
ip address 192.168.100.5 255.255.255.252
!
!
interface f0/0.30
description VLAN 30 client
encapsulation dot1q 30
ip address 192.168.100.1 255.255.255.252
!
router rip
version 2
no auto-summary
network 192.168.100.0
!

========================================

client 1

!
hostname EthCLient1
!
interface f0/0
description Link to Ether Agg
ip address 192.168.100.10 255.255.255.252
no shut

router rip
version 2
no auto-summary
network 192.168.100.0
!

-----------
client 2

hostname EthCLient2
!
interface f0/0
description Link to Ether Agg
ip address 192.168.100.6 255.255.255.252
no shut

router rip
version 2
no auto-summary
network 192.168.100.0
!

-----------
client 3

hostname EthCLient3
!
interface f0/0
description Link to Ether Agg
ip address 192.168.100.2 255.255.255.252
no shut

router rip
version 2
no auto-summary
network 192.168.100.0
!

Open in new window


I have attached a conceptual diagram

Conceptual diagram of Ethernet aggregator
Commented:
I really have no idea what the answers above are about...

Anyway, we are talking about IP traffic here.

On your Ethernet interfaces you have.... Ethernet as your Layer 2 protocol (encapsulation).

Now you just need to decide what encapsulation you want on the E1 circuits. The main options are HDLC, PPP and Frame Relay. Specifically, it has to match what you have on the other end of the E1 lines. If these connect to an ISP, you need to ask them what encapsulation to use.

Above someone pasted in a Cisco URL, on how to configure the E1 - and you said you configured as unframed. Also the E1 configuration must match the other side - so again you need to ask the ISP. Once the E1 is configured, you put your encapsulation and IP address on the Serial interface (see the cisco url) and you are done.

You know the IP routing, you have said.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
well, thanks for your answers everyone, pergr you are correct but here's what finally happened:

I configured the router as per the cisco URL example and matched everything to the provider's configuration of E1s. And it probably would have worked! BUT...

...the signaling protocol was, after all, SS7, which is simply not supported by 7206. We are therefore in the search for another solution altogether.

Argh.

Commented:
SS7 is a voice signalling protocol, and so all time-slots in the E1 would have been voice, not IP.

For voice you need the PA-VXC or PA-MCX, but anyway, for SS7 you need also a signalling controller. Cisco has the PGW, but possibly it does not work with the 7200 - only with the AS5400.

Author

Commented:
Yes, but I also found this one: Q703 ITP SS7 High Speed Link (HSL) Port Adapter

Looks like it might do the job, still searching though.

what I will most likely buy after all is something like:

http://www.squire-technologies.co.uk/products/svi-mg1000_specifications.php

Commented:
You also need this
http://www.squire-technologies.co.uk/products/svi-mgc.php
but call Oliver at Squire and check with them...

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial