Link to home
Start Free TrialLog in
Avatar of ianmal2
ianmal2

asked on

Cetificate error when trying to connect to Exchange Server (SBS2003)

Trying to connect Outlook to remote SBS 2003 Exchange Server using RPC over HTTP.  Keep getting certificate error message.

When I try to access remote in IE 9 there is no option to install/trust certificate.  I have tried opening IE 9 as an administrator still no joy.

What next to get rid of this blasted error?

Thanks.
Avatar of neilpage99
neilpage99
Flag of United States of America image

What's the error please?
Have you tried adding the site to your trusted sites?

Internet Options -> Security -> Trusted Sites

Another thing to look at is whether you have a certificate associated with the site added to your certificate stores. You can check this through the MMC certificate snap-in.
Avatar of ianmal2
ianmal2

ASKER

When Outlook tries to connect you get the logon screen then after entering credentials Outlook gives the error;

"There is a problem with the proxy server's security certificate. The security certificate is not from a trusted certifying authority.  Outlook is unable to connect to the proxy server remote.company.com (error code 8)"

Made site a trusted site in IE9 - still comes up with a certificate error

IshaanRawat - thanks for your detailed information.

I'm hoping there's an easy way round this because I have about six remote users who need to connect their Outlook this way.  After all I know the server is trusted.
ASKER CERTIFIED SOLUTION
Avatar of Jeffrey Kane - TechSoEasy
Jeffrey Kane - TechSoEasy
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of ianmal2

ASKER

Hi TechSoEasy,

Got there at the same time.  Here's what I found which is effectively what you are saying.

http://mhakim.web.id/how-to-fix-error-code-8-on-microsoft-outlook/

The thing that threw me was there was no lock icon.  The article correctly mentioned the address bar also like you.  This IE9 is drivin' me crazy!