Cisco HWIC-1DSU-T1 Config for MPLS

Lee Anderson
Lee Anderson used Ask the Experts™
on
Hello,

I am fairly new(b) to configuring Cisco routers for MPLS. My scenario is this: We just establish a MPLS network with Earthlink a few months ago between two locations with four bonded T1's. At the time it was decided to have Eathlink provide the router for that connection and all is working well there.

We recently decided to add another location to our MPLS network however this time it was decided that we would provide the router for this location.

So we purchased a Cisco 1921 with a HWIC-1DSU-T1 card. For the configuration of the serial interface I have:

interface Serial0/0/0
 ip address 10.168.0.10 255.255.255.252
 encapsulation ppp
 no shutdown

Open in new window


When we connect to the circuit, I get nothing. The interface stays in a line protocol down
state.

Am I missing something on the configuration of this interface for MPLS?

Below is what the network looks like. Earthlink assigned the 10.168.0.8/30 subnet to this network. 10.168.0.9 being the provider edge router and 10.168.0.10 being the customer edge (our) router.

If there is a need to attach the whole config for this router I can.

Thanks in advance!!!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2012

Commented:
It might be better if you attach the whole config and a show version command. Did Earthlink give you some information about the linecode and framing? I am not sure if the interface you are configuring is really the HWIC-1DSU-T1 because I expect the serial interface to look something like Sx/x/x:0 (I might be wrong though, it's some time since I last configured this).

Do you see something like this in the config:
controller T1 1/0
 framing esf
 linecoding b8zs
 clock source line
channel-group 0 timeslots 1-24
Lee AndersonVP, CIO

Author

Commented:
Earthlink did not give me any information on the linecode or framing.

I do however have access to their routers and I have attached their config as well. One thing to note is that their router is bonding 4 T1s for this location and the location I am adding is only 1 T1.

My Router
Router-31#sh run
Building configuration...

Current configuration : 4836 bytes
!
! No configuration change since last restart
version 15.1
service timestamps debug uptime
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname Router-31
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
!
aaa new-model
!
!
aaa authentication attempts login 2
aaa authentication banner ^C
This system is for authorized users only. Use of this
computer system without authority,or in excess of 
authority,is subject to having all activities on this
system monitored and recorded by systems personnel.
In the course of monitoring individuals improperly 
using this system, or in the course of system 
maintenance,the activities of authorized users may
also be monitored. Anyone using this system expressly
consents to such monitoring and is advised that if
such monitoring reveals possible criminal activity
or policy violation, system personnel may provide the
evidence of such monitoring to law enforcement or
other officials.
^C
aaa authentication fail-message ^C
This is a Private System all login
attempts are logged. If you feel 
you have reached this message in
error please contact your supervisor.
^C
aaa authentication password-prompt "Please Enter Your Password"
aaa authentication username-prompt "Please Enter Your Username"
aaa authentication login con local
aaa authentication enable default enable
!
!
!
!
!
aaa session-id common
!
clock timezone EST -5 0
clock summer-time EDT recurring
!
no ipv6 cef
ip source-route
ip cef
!
!
!
no ip dhcp use vrf connected
!
!
ip domain name XXXXXXX.XXX
ip name-server 10.0.6.50
ip name-server 10.0.6.51
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-1233492277
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1233492277
 revocation-check none
 rsakeypair TP-self-signed-1233492277
!
!
crypto pki certificate chain TP-self-signed-1233492277
 certificate self-signed 01
!
!
username XXXXXXXXXXX privilege 15 secret 5 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
!
redundancy
!
!
!
!
! 
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 172.16.1.153 255.255.255.248
 no shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 10.168.0.10 255.255.255.252
 encapsulation ppp
 no shutdown
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 10.168.0.1
ip route 10.0.0.0 255.255.255.0 192.168.3.82
ip route 10.0.6.0 255.255.255.0 192.168.3.82
!
!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 transport input telnet ssh
line vty 5 15
 privilege level 15
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp server 172.16.3.1
end

Router-31#

Open in new window


Their Router (Adtran)
!
!
! ADTRAN, Inc. OS version A4.09.00.E
! Boot ROM version 14.05.00.SA
! Platform: Total Access 908e (2nd Gen), part number 4242908L5
! Serial number CFG0971235
!
!
hostname "20/FRML/XXXXXX"
enable password XXXXXXXX
!
!
ip subnet-zero
ip classless
ip routing
!
!
!
!
no auto-config
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "XXXXXXX" password "XXXXXXXX"
username "XXXXXXX" password "XXXXXXXX"
!
banner motd #
*********************************************
* UNAUTHORIZED ACCESS IS PROHIBITED!!!! *
* VIOLATORS WILL BE PROSECUTED TO *
* THE FULLEST EXTENT!!!! *
*********************************************
#
!
!
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
no dot11ap access-point-control
!
!
!
!
!
!
!
!
!
!
qos map eth-out-4T1 10
  match dscp 46
  priority unlimited
  set dscp 63
!
!
!
!
interface loop 1
  ip address  2.8.24.171  255.255.255.255 
  no shutdown
!
interface eth 0/1
  ip address  192.168.3.81  255.255.255.252 
  no shutdown
!
!
interface eth 0/2
  no ip address
  shutdown
!
!
!
!
interface t1 0/1
  tdm-group 1 timeslots 1-24 speed 64
  no shutdown
!
interface t1 0/2
  tdm-group 1 timeslots 1-24 speed 64
  no shutdown
!
interface t1 0/3
  tdm-group 1 timeslots 1-24 speed 64
  no shutdown
!
interface t1 0/4
  tdm-group 1 timeslots 1-24 speed 64
  no shutdown
!
!
interface fxs 0/1
  no shutdown
!
interface fxs 0/2
  no shutdown
!
interface fxs 0/3
  no shutdown
!
interface fxs 0/4
  no shutdown
!
interface fxs 0/5
  no shutdown
!
interface fxs 0/6
  no shutdown
!
interface fxs 0/7
  no shutdown
!
interface fxs 0/8
  no shutdown
!
!
interface fxo 0/0
  no shutdown
!
interface ppp 1
  ip address  10.168.0.2  255.255.255.252 
  ppp multilink
  max-reserved-bandwidth 100
  qos-policy out eth-out-4T1
  no shutdown
  cross-connect 1 t1 0/1 1 ppp 1
  cross-connect 2 t1 0/2 1 ppp 1
  cross-connect 3 t1 0/3 1 ppp 1
  cross-connect 4 t1 0/4 1 ppp 1
!
!
!
!
timing-source t1 0/1
!
timing-source t1 0/2 secondary
!
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 10.168.0.1
ip route 10.0.0.0 255.255.255.0 192.168.3.82
ip route 10.0.1.0 255.255.255.0 192.168.3.82
ip route 10.0.2.0 255.255.255.0 192.168.3.82
ip route 10.0.3.0 255.255.255.0 192.168.3.82
ip route 10.0.3.0 255.255.255.192 192.168.3.82
ip route 10.0.3.128 255.255.255.192 192.168.3.82
ip route 10.0.4.0 255.255.255.0 192.168.3.82
ip route 10.0.6.0 255.255.255.0 192.168.3.82
ip route 66.0.15.200 255.255.255.248 ppp 1
ip route 192.168.3.84 255.255.255.252 ppp 1
!
no ip tftp server
no ip tftp server overwrite
ip http server
no ip http secure-server
ip snmp agent
no ip ftp server
no ip scp server
no ip sntp server
!
!
!
!
auto-link
auto-link server 66.0.15.206
!
!
ip sip
ip sip udp 5060
no ip sip tcp
!
!
!
voice feature-mode network
voice forward-mode network
!
end

Open in new window

Commented:
Can you also attache the output of:
show interface Serial0/0/0

Possibly also this, if that exists:
show controller Serial0/0/0
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Lee AndersonVP, CIO

Author

Commented:
sh interface serial0/0/0
Serial0/0/0 is administratively up, line protocol is down
  Hardware is GT96K with integrated T1 CSU/DSU
  Internet address is 10.168.0.10/30
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed, loopback not set
  Keepalive set (10 sec)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 4d02h
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=down  DSR=up  DTR=down  RTS=down  CTS=down

Open in new window


show controller serial0/0/0
Interface Serial0/0/0
Hardware is SCC with Integrated FT1 CSU/DSU module

Clock Freq detected Rx clk/Tx clk 1472542/1472542 (+-10%)

idb at 0x3065353C, driver data structure at 0x283A4CE0
wic_info 0x3065A458

WIC Serial Global Registers: (0x10490000)
----------------------------
sti_errintr_en      (0004): 0x00000000  scc_ctrl_regs       (1004): 0x0020
mgmt_intr_status    (1010): 0x0010      netio_intr_status   (1012): 0x0000
mgmt_intr_enable    (1020): 0x00CA      netio_intr_enable   (1022): 0x0000
timer_0_7_enable    (1024): 0x0000      timer_16_19_enable  (1026): 0x0000
timer_0_1_program   (1030): 0x0000      timer_2_3_program   (1032): 0x0000
timer_4_5_program   (1034): 0x0000      timer_6_7_program   (1036): 0x0000
timer_16_program    (1040): 0x0000      timer_17_program    (1042): 0x0000
timer_18_program    (1044): 0x0000      timer_19_program    (1046): 0x0000

WIC Serial SCC Registers: (0)
----------------------------
ch_mode_cfg         (1100): 0x08019031  ch_flag_cfg         (1104): 0x007E
ch_flwctrl_cfg      (1108): 0x0000      ch_intr_enable      (110C): 0x0000
ch_cmd_stat         (110E): 0x0028

WIC Serial DMA Registers:
-------------------------
Rx ring_start_ptr   (2000): 0x0EA8E080  Rx ring_mask_index  (2004): 0x00F80000
internal_desc_stat  (2008): 0x0400060C  internal_buff_addr  (200C): 0x0EA9C0E0
internal_context    (2010): 0x00000000  internal_fifo_data  (2014): 0x0EA9C0E0

Tx ring_start_ptr   (2200): 0x0EA90080  Tx ring_mask_index  (2204): 0x03F80000
internal_desc_stat  (2208): 0x00000000  internal_buff_addr  (220C): 0x00000000
internal_context    (2210): 0x00000000  internal_fifo_data  (2214): 0x00000000

WIC Serial Interface Registers:
-------------------------------
intf_ctrl           (3000): 0x1000      modem_ctrl          (3002): 0xA010
flow_ctrl           (3004): 0x1020      brg dvdr            (3006): 0x0000

WIC TDM/FREQ Counter Registers:
--------------------------------
tdm_control         (3100): 0x0000      tdm_a_8k_divider    (3102): 0x0000
tdm_b_8k_divider    (3104): 0x0000
freq_count_port_sel (310A): 8           freq_count          (310C):  1030779

TDM Control Registers:
----------------------
  tmdsw_ctl                              (addr 0x104B0040): 0x0000000D
  vmcr[0]                                (addr 0x104B0060): 0x0000000D
  vmcr[1]                                (addr 0x104B0064): 0x0000000D
  vmcr[2]                                (addr 0x104B0068): 0x0000000D
  vmcr[3]                                (addr 0x104B006C): 0x0000000D
  ntr_cr0                                (addr 0x104B0078): 0x0000000D
  ntr_cr1                                (addr 0x104B0080): 0x0000000D
  tpllr_cr                               (addr 0x104B0088): 0x25110000
  sm_tdm_cr                              (addr 0x104B0070): 0x0000000D
  pvdm_tdm_cr                            (addr 0x104B0074): 0x0000000D

0 input aborts on receiving flag sequence
0 throttles, 0 enables
0 overruns
0 transmitter underruns
0 transmitter CTS losts
0 rxintr, 0 txintr, 0 rxerr, 0 txerr
0 tx_abort 0 tx_reset

tx_limited = 1(2) tx_count = 0
idb at 0x3065353C, driver data structure at 0x283A4CE0
Receive Ring
rxr head (0)(0x0EA8E080), rxr tail (0)(0x0EA8E080)
  rmd(EA8E080): stats_len 8400060C buff_addr EA9C0E0
  rmd(EA8E088): stats_len 8400060C buff_addr EA9C740
  rmd(EA8E090): stats_len 8400060C buff_addr EA9CDA0
  rmd(EA8E098): stats_len 8400060C buff_addr EA9D400
  rmd(EA8E0A0): stats_len 8400060C buff_addr EA9DA60
  rmd(EA8E0A8): stats_len 8400060C buff_addr EA9E0C0
  rmd(EA8E0B0): stats_len 8400060C buff_addr EA9E720
  rmd(EA8E0B8): stats_len 8400060C buff_addr EA9ED80
  rmd(EA8E0C0): stats_len 8400060C buff_addr EA9F3E0
  rmd(EA8E0C8): stats_len 8400060C buff_addr EA9FA40
  rmd(EA8E0D0): stats_len 8400060C buff_addr EAA00A0
  rmd(EA8E0D8): stats_len 8400060C buff_addr EAA0700
  rmd(EA8E0E0): stats_len 8400060C buff_addr EAA0D60
  rmd(EA8E0E8): stats_len 8400060C buff_addr EAA13C0
  rmd(EA8E0F0): stats_len 8400060C buff_addr EAA1A20
  rmd(EA8E0F8): stats_len 8400060C buff_addr EAA2080
  rmd(EA8E100): stats_len 8400060C buff_addr EAA26E0
  rmd(EA8E108): stats_len 8400060C buff_addr EAA2D40
  rmd(EA8E110): stats_len 8400060C buff_addr EAA33A0
  rmd(EA8E118): stats_len 8400060C buff_addr EAA3A00
  rmd(EA8E120): stats_len 8400060C buff_addr EAA4060
  rmd(EA8E128): stats_len 8400060C buff_addr EAA46C0
  rmd(EA8E130): stats_len 8400060C buff_addr EAA4D20
  rmd(EA8E138): stats_len 8400060C buff_addr EAA5380
  rmd(EA8E140): stats_len 8400060C buff_addr EAA59E0
  rmd(EA8E148): stats_len 8400060C buff_addr EAA6040
  rmd(EA8E150): stats_len 8400060C buff_addr EAA66A0
  rmd(EA8E158): stats_len 8400060C buff_addr EAA6D00
  rmd(EA8E160): stats_len 8400060C buff_addr EAA7360
  rmd(EA8E168): stats_len 8400060C buff_addr EAA79C0
  rmd(EA8E170): stats_len 8400060C buff_addr EAA8020
  rmd(EA8E178): stats_len 8400060C buff_addr EAA8680
Transmit Ring
txr head (0)(0x0EA90080), txr tail (0)(0x0EA90080)
  tmd(EA90080): sts_len 00000000 buf_addr 0
  tmd(EA90088): sts_len 00000000 buf_addr 0
  tmd(EA90090): sts_len 00000000 buf_addr 0
  tmd(EA90098): sts_len 00000000 buf_addr 0
  tmd(EA900A0): sts_len 00000000 buf_addr 0
  tmd(EA900A8): sts_len 00000000 buf_addr 0
  tmd(EA900B0): sts_len 00000000 buf_addr 0
  tmd(EA900B8): sts_len 00000000 buf_addr 0
  tmd(EA900C0): sts_len 00000000 buf_addr 0
  tmd(EA900C8): sts_len 00000000 buf_addr 0
  tmd(EA900D0): sts_len 00000000 buf_addr 0
  tmd(EA900D8): sts_len 00000000 buf_addr 0
  tmd(EA900E0): sts_len 00000000 buf_addr 0
  tmd(EA900E8): sts_len 00000000 buf_addr 0
  tmd(EA900F0): sts_len 00000000 buf_addr 0
  tmd(EA900F8): sts_len 00000000 buf_addr 0
  tmd(EA90100): sts_len 00000000 buf_addr 0
  tmd(EA90108): sts_len 00000000 buf_addr 0
  tmd(EA90110): sts_len 00000000 buf_addr 0
  tmd(EA90118): sts_len 00000000 buf_addr 0
  tmd(EA90120): sts_len 00000000 buf_addr 0
  tmd(EA90128): sts_len 00000000 buf_addr 0
  tmd(EA90130): sts_len 00000000 buf_addr 0
  tmd(EA90138): sts_len 00000000 buf_addr 0
  tmd(EA90140): sts_len 00000000 buf_addr 0
  tmd(EA90148): sts_len 00000000 buf_addr 0
  tmd(EA90150): sts_len 00000000 buf_addr 0
  tmd(EA90158): sts_len 00000000 buf_addr 0
  tmd(EA90160): sts_len 00000000 buf_addr 0
  tmd(EA90168): sts_len 00000000 buf_addr 0
  tmd(EA90170): sts_len 00000000 buf_addr 0
  tmd(EA90178): sts_len 00000000 buf_addr 0
  tmd(EA90180): sts_len 00000000 buf_addr 0
  tmd(EA90188): sts_len 00000000 buf_addr 0
  tmd(EA90190): sts_len 00000000 buf_addr 0
  tmd(EA90198): sts_len 00000000 buf_addr 0
  tmd(EA901A0): sts_len 00000000 buf_addr 0
  tmd(EA901A8): sts_len 00000000 buf_addr 0
  tmd(EA901B0): sts_len 00000000 buf_addr 0
  tmd(EA901B8): sts_len 00000000 buf_addr 0
  tmd(EA901C0): sts_len 00000000 buf_addr 0
  tmd(EA901C8): sts_len 00000000 buf_addr 0
  tmd(EA901D0): sts_len 00000000 buf_addr 0
  tmd(EA901D8): sts_len 00000000 buf_addr 0
  tmd(EA901E0): sts_len 00000000 buf_addr 0
  tmd(EA901E8): sts_len 00000000 buf_addr 0
  tmd(EA901F0): sts_len 00000000 buf_addr 0
  tmd(EA901F8): sts_len 00000000 buf_addr 0
  tmd(EA90200): sts_len 00000000 buf_addr 0
  tmd(EA90208): sts_len 00000000 buf_addr 0
  tmd(EA90210): sts_len 00000000 buf_addr 0
  tmd(EA90218): sts_len 00000000 buf_addr 0
  tmd(EA90220): sts_len 00000000 buf_addr 0
  tmd(EA90228): sts_len 00000000 buf_addr 0
  tmd(EA90230): sts_len 00000000 buf_addr 0
  tmd(EA90238): sts_len 00000000 buf_addr 0
  tmd(EA90240): sts_len 00000000 buf_addr 0
  tmd(EA90248): sts_len 00000000 buf_addr 0
  tmd(EA90250): sts_len 00000000 buf_addr 0
  tmd(EA90258): sts_len 00000000 buf_addr 0
  tmd(EA90260): sts_len 00000000 buf_addr 0
  tmd(EA90268): sts_len 00000000 buf_addr 0
  tmd(EA90270): sts_len 00000000 buf_addr 0
  tmd(EA90278): sts_len 00000000 buf_addr 0
  tmd(EA90280): sts_len 00000000 buf_addr 0
  tmd(EA90288): sts_len 00000000 buf_addr 0
  tmd(EA90290): sts_len 00000000 buf_addr 0
  tmd(EA90298): sts_len 00000000 buf_addr 0
  tmd(EA902A0): sts_len 00000000 buf_addr 0
  tmd(EA902A8): sts_len 00000000 buf_addr 0
  tmd(EA902B0): sts_len 00000000 buf_addr 0
  tmd(EA902B8): sts_len 00000000 buf_addr 0
  tmd(EA902C0): sts_len 00000000 buf_addr 0
  tmd(EA902C8): sts_len 00000000 buf_addr 0
  tmd(EA902D0): sts_len 00000000 buf_addr 0
  tmd(EA902D8): sts_len 00000000 buf_addr 0
  tmd(EA902E0): sts_len 00000000 buf_addr 0
  tmd(EA902E8): sts_len 00000000 buf_addr 0
  tmd(EA902F0): sts_len 00000000 buf_addr 0
  tmd(EA902F8): sts_len 00000000 buf_addr 0
  tmd(EA90300): sts_len 00000000 buf_addr 0
  tmd(EA90308): sts_len 00000000 buf_addr 0
  tmd(EA90310): sts_len 00000000 buf_addr 0
  tmd(EA90318): sts_len 00000000 buf_addr 0
  tmd(EA90320): sts_len 00000000 buf_addr 0
  tmd(EA90328): sts_len 00000000 buf_addr 0
  tmd(EA90330): sts_len 00000000 buf_addr 0
  tmd(EA90338): sts_len 00000000 buf_addr 0
  tmd(EA90340): sts_len 00000000 buf_addr 0
  tmd(EA90348): sts_len 00000000 buf_addr 0
  tmd(EA90350): sts_len 00000000 buf_addr 0
  tmd(EA90358): sts_len 00000000 buf_addr 0
  tmd(EA90360): sts_len 00000000 buf_addr 0
  tmd(EA90368): sts_len 00000000 buf_addr 0
  tmd(EA90370): sts_len 00000000 buf_addr 0
  tmd(EA90378): sts_len 00000000 buf_addr 0
  tmd(EA90380): sts_len 00000000 buf_addr 0
  tmd(EA90388): sts_len 00000000 buf_addr 0
  tmd(EA90390): sts_len 00000000 buf_addr 0
  tmd(EA90398): sts_len 00000000 buf_addr 0
  tmd(EA903A0): sts_len 00000000 buf_addr 0
  tmd(EA903A8): sts_len 00000000 buf_addr 0
  tmd(EA903B0): sts_len 00000000 buf_addr 0
  tmd(EA903B8): sts_len 00000000 buf_addr 0
  tmd(EA903C0): sts_len 00000000 buf_addr 0
  tmd(EA903C8): sts_len 00000000 buf_addr 0
  tmd(EA903D0): sts_len 00000000 buf_addr 0
  tmd(EA903D8): sts_len 00000000 buf_addr 0
  tmd(EA903E0): sts_len 00000000 buf_addr 0
  tmd(EA903E8): sts_len 00000000 buf_addr 0
  tmd(EA903F0): sts_len 00000000 buf_addr 0
  tmd(EA903F8): sts_len 00000000 buf_addr 0
  tmd(EA90400): sts_len 00000000 buf_addr 0
  tmd(EA90408): sts_len 00000000 buf_addr 0
  tmd(EA90410): sts_len 00000000 buf_addr 0
  tmd(EA90418): sts_len 00000000 buf_addr 0
  tmd(EA90420): sts_len 00000000 buf_addr 0
  tmd(EA90428): sts_len 00000000 buf_addr 0
  tmd(EA90430): sts_len 00000000 buf_addr 0
  tmd(EA90438): sts_len 00000000 buf_addr 0
  tmd(EA90440): sts_len 00000000 buf_addr 0
  tmd(EA90448): sts_len 00000000 buf_addr 0
  tmd(EA90450): sts_len 00000000 buf_addr 0
  tmd(EA90458): sts_len 00000000 buf_addr 0
  tmd(EA90460): sts_len 00000000 buf_addr 0
  tmd(EA90468): sts_len 00000000 buf_addr 0
  tmd(EA90470): sts_len 00000000 buf_addr 0
  tmd(EA90478): sts_len 00000000 buf_addr 0

buffer size 1524

Open in new window

Commented:
Are you sure you should be using PPP as encapsulation?
Did you try with HDLC encapsulation?
Commented:
Actually, you may need either:


Interface serial 0/0/
service-module t1 clock source line
service-module t1 timeslots 1-24 speed 64
service-module t1 framing esf
service-module t1 linecode b8zs


or


Service-module t1 timeslots all
Service-module t1 clock source line
Service-module t1 linecode b8zs
Service-module t1 framing esf
Lee AndersonVP, CIO

Author

Commented:
I am not sure that it should be ppp encapsulation. I will try configuring the s0/0/0 interface as suggest. I will not be able to get onsite with the router until next Tues. I will update the question when I am able to test.
Lee AndersonVP, CIO

Author

Commented:
I tried both senarios mentioned for hdlc encapsation. However, both options did not work. I  am at least getting the serial interface to come up administratively however line protocol remains down.

Commented:
Did you try both:

service-module t1 timeslots 1-24 speed 64

and

service-module t1 timeslots all

Essentially, those settings must also match between your side and the provider.
Lee AndersonVP, CIO

Author

Commented:
Hi Pergr,

I actually found out the issue right after I posted my response earlier. You had it right originally. I forgot that I was trying HDLC encapsulation and forgot to switch back to ppp.

I switched back to 'encapsulation ppp' with your second set of settings and the line came right up:
Router#configure terminal
Router(config)#int s0/0/0
Router(config-if)#encapsulation ppp
Router(config-if)#Service-module t1 timeslots all
Router(config-if)#Service-module t1 clock source line
Router(config-if)#Service-module t1 linecode b8zs
Router(config-if)#Service-module t1 framing esf

Open in new window

Thanks for the help!!!

Commented:
I am not sure if you have closed this question in the right way - typically you award the points, and then it closes immediately.
Lee AndersonVP, CIO

Author

Commented:
Using pergr second recommendation with 'encapsulation ppp' was the correct config to this issue. Thanks.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial