Link to home
Start Free TrialLog in
Avatar of pepps11976
pepps11976

asked on

NTP Settings on a Domain controller

Hi All

I am having trouble getting the correct time om my DC it always seems to be 5 Minutes slow

i have edidted the following Reg Key with the following

Reg key: HKLM>SYSTEM>CurrentControlSet>services>W32Time>Parameters>NtpServer>chronos.csr.net,0x1

yet the time still appears to be wrong we are based in london and if i go to a website such as

http://www.timeanddate.com/

then my server will be 5 mins slow

Can anyone help

John
Avatar of IanTh
IanTh
Flag of United Kingdom of Great Britain and Northern Ireland image

try pool.ntp.org I have found that is spot on
Avatar of pepps11976
pepps11976

ASKER

Yes tried that and still seem to get the same time
SOLUTION
Avatar of 2Cs
2Cs
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
could you talk me through setting via command line?
ASKER CERTIFIED SOLUTION
Avatar of ArneLovius
ArneLovius
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
ArneLovius

great thats done it where in the machine does it place all the ntp values ie: the registry?

john
Yep.
Yes, it sets the registry, but without having to manually edit the registry :-)

It also ensures that you won't get any typos in the configuration, apart from an incorrect hostname of course...
Just one more question ArneLovius

If i try to add this to my other DC

and then do a w32tm /resync i get the following message

The Computer did not resync because no time data was availiable
you have to wait a few minutes for ntp
as IanTh said, you might have to wait a short time.

You can force this by stopping and starting the windows time service.

from an elevated command prompt

net stop w32time && net start w32time

Open in new window

You should really only have your PDC going out to an external time source and then all other DC's syncing to your PDC.
Thanks for your help Guys
@2Cs In an AD environment I would have each DC run NTP, so that in the event of the PDC emulator role being moved to a different server for maintenance, it does not sync to itself.
@ArneLovius it is bad practice to advise every administrator to set all DC's to use external time sources. If you are moving a role then you would need to update GPO to reflect this anyway, so why not make the change if the role is going to be permanent.

Glad the issue is now resolve pepps.
I wouldn't use ntp and pdc in the same domain that can cause problems
I am only suggesting running NTP on the domain controllers, so that they will then advertise as a valid time source

If you have non Windows workstations, they can then use the Domain Controllers as NTP servers.

Windows workstations should usually use Windows time for time sync. An exception might  be if you needed a high accuracy time sync across workstations, in which case you might  operate an internal NTP service based on a low drift source such as a Caesium clock.