We help IT Professionals succeed at work.

Replacing Exchange 2010 server

origintech
origintech asked
on
459 Views
Last Modified: 2012-10-15
I had an Exchange 2010 Server installed and working. I have a new server that will be replacing the old one. I installed exchange on the new box and moved the mailboxes. When I took the old server down I could not get to OWA and Outlook was still looking for the old exchange server when I created a new mail profile. It seems as though mail comes into the old box and outlook connects to the old box. The mailboxes exist on the new server and all outgoing mail gets sent through the new server. I followed the instructions from this link, https://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26421719.html. Please let me know if you have any advise on how to get this configured correctly.
Comment
Watch Question

Paul MacDonaldDirector, Information Systems
CERTIFIED EXPERT

Commented:
Is DNS properly configured to point to the new server?

Author

Commented:
I changed the new servers IP to the old servers IP when I took the old server down. I then removed the DNS entry for the old server and flushed/registered. INET and network browsing worked fine to the new server. When I tried to setup Outlook it kept looking for the old server name. I dont know how Outlook finds the exchange server so I dont know how to resolve that issue. Are the steps I took the correct steps?
Paul MacDonaldDirector, Information Systems
CERTIFIED EXPERT

Commented:
Sounds like you've done everything okay so far.  

If the new server is using the same IP as the old server, this probably isn't a locating issue.  Are you sure the IIS stuff is set up properly on the new server?  That's how Outlook does autodiscover.  Also, since you're having trouble with OWA, that lends credence to that as a possibility.

This link explains how to remove/re-create the OWA directories:
http://technet.microsoft.com/en-us/library/aa998849.aspx

Then make sure they're configured correctly:
http://technet.microsoft.com/en-us/library/dd298140.aspx

Author

Commented:
I am going to take a look at these steps now. I dont remember having to change anything by default in IIS the first time around. Is there something I need to do when I remove the old server from the network so there is no reference to it?
Paul MacDonaldDirector, Information Systems
CERTIFIED EXPERT

Commented:
No.  Sometimes OWA doesn't get set up properly, so it has to be re-created.

Author

Commented:
I have taken the old server offline. I launch outlook and it asks me for credentials. I also get an error message that says "there is a problem with the proxy server's security certificate. The security certificate is not from a trusted certifying authority. Outlook is unable to connect to the proxy server mail.origintechnologies.com. (Error Code 18)". I also get a security alert asking me if I want to proceed with the certificate. I currently have 1 self signed, and one non self signed cert on the server. Please let me know how I can fix all of this.

P.S.
I just took a look at outlook settings and it is setup to connect to Microsoft Exchange using HTTP. I did not set this up. This was setup on the new profile with autodiscover.
Paul MacDonaldDirector, Information Systems
CERTIFIED EXPERT

Commented:
Are you using a proxy server?  Does it have both certificates installed?  

Also, it may be your old server had HTTPS turned off and so didn't require an SSL certificate for Outlook.

Author

Commented:
Both certificates are installed. One is for out external and one was created by exchange. I am assuming that is for internal as the name on it is the name of the new server. I do not want to use a proxy server for outlook on the domain. For some reason when I launch outlook it changed settings in outlook. It is now set to use a proxy when it was not before. HTTPS was turned on on the old server.
Michael W. KroutCEO/President

Commented:
The default configuration for OWA is SSL.   There is a service which is called the AutoDiscover service.   Open up the Exchange Management Shell and type the following:

get-clientaccessserver | fl

This will give a full listing of the CAS servers within the organization.   Have you moved all of the mailboxes off the other server?   Do you have public folders on the old server?   If so have you removed them.   You would need to replicate the public folders over to the new server.  This is the best way.   Once everything is replicated then you can remove the databases.  

You should not use a self-signed certificate.  What you should do is use the Certificate Wizard and create a new request.   Copy this information into your internal CA http://SERVERNAME/Certsrv or Certsvr or your Third Party.   Once you get your .cer then you need to complete the proces.   This will make sure you have the correct cert for the OWA.   You should get a multiple subject alternate name this is known as SAN certificate.   You will include all of the names such as EX01, EX01.newvisions.com etc.

To test your Outlook configuration you would go to your status bar and do a CTRL-Right click on the Outlook icon.  This will allow you to test the autoconfiguration.   Only select the first check box.  

Once you have moved the mailboxes and the databases then you should be able to demote the Exchange Server 2010 server.   Now you will have to redirect clients to the new server by changing the External addresses.   This is done through a Wizard on the CAS server you will find this on the Action Menu.   A records will be need to changed also.   As soon as the mailboxes have been moved Exchange should automatically redirect the mail to the right Mailbox server.   OWA should be redirected also.   You need to make sure you have a Global Catalog server within the site .  The Configuration Partition has all of the AD configuration stored in there and the information about the Exchange Servers.  

Let me know if you have any more questions,

Thanks,

Idea Dudes

Please join us for our Webinar Exchange Server 2010 - 6/8 - https://www.clicktoattend.com/invitation.aspx?code=160579

Also join us for Windows Server 2008 R2 - Active Directory - 6/6 - http://blog.experts-exchange.com/ee-blog/register-today-for-a-windows-server-2008-r2-webinar/

Author

Commented:
I will leave the certificate issue till everything else is done. My issue now is outlook automatically is reverting itself to Connect to Exchange using HTTP. Also, Outlook Anywhere was setup on the old box and is not working on this box. When I enter get-clientaccessserver | fl, it shows me outlook anywhere is not enabled. I dont see how this is possible as my domain PC is using http and is connecting. I have just enabled outlook anywhere as it was failing previously. I believe autodiscover is configuring the outlook clients to use http. is there any way to change this as I dont want that to be default. Please let me know. Thank you.
Michael W. KroutCEO/President

Commented:
RPC over HTTPS is not enabled by default.   You need to click on the CAS server in the Server node of the EMC.   You need to enable Outlook Anywhere.   Just click on the Action menu for Enable Outlook Anywhere.   That is the step that you are missing.   Exchange Server 2007 should be using https for OWA by default.  What happens when you do https://server/owa?  You should be redirected to a logon page or a certificate warning and then the OWA logon page.

If you want to do a Join.me session , I can help you with this issue.   Contact me at michael@ideadudestraining.com.

Let me know if you have any other questions,

Thanks,

Idea Dudes

Author

Commented:
OWA has always been working. The certificate is good as it is from godaddy.com. Outlook Anywhere was disabled and erroring when I tried to enable it. This is why I was confused when my outlook was configured automatically to use HTTP and was working. I now enabled Outlook Anywhere and it went through. My main concern now is with Outlook converting to HTTP without me telling it to. Again, I think somehow it is Autodiscover that is doing this. Is there a way to tell what autodiscover is doing and change that.

Author

Commented:
Where can I change the settings outlook takes when it is being setup on the domain automatically? This is configuring Outlook to use HTTP and I do not want it like that internally.
Connect-to-Microsoft-Exchange-us.docx. Please advise how I can fix this.
Michael W. KroutCEO/President

Commented:
Check under the CAS server and look at OWA.   You will see a tab that say Authentication.   In the Authentication tab you should see Use forms based authentication.   Also check the General tab and look at the Internal and External URL settings.   They should be in the form of

Internal URL:

https://emailserver/owa

External URL:

https://mail.domainname.com/owa

Make sure that you have your A record like mail or whatever and it is pointing to the External URL.

Let me know if you need more information,

Thanks,

Idea Dudes

If you need help, I can connect to your machine to show you what to do by using join.me.   I will do this at no charge just to help you out.  Let me know if you want this help.

Author

Commented:
The CAS server is setup to use "forms based authentication".  The internal and external url's are fine. Internal is https://servername.domainname.local/owa and external is https://mail.externaldomainname.com/owa. I am not sure if I am correct in saying this, but isn't OWA for outlook web access and not the internal outlook?
Michael W. KroutCEO/President

Commented:
Oh, I am sorry.   I thought you were having issues with OWA,   Did you enable Outlook Anywhere?   This done by selecting the CAS server and then clicking on the action.   There is not much for installing.   Just make sure that you installed RPC_HTTP feature.   You will find this under the Server Manager.   This has to be installed on all CAS servers that is configured to use Outlook Anywhere.   Then you  should be good with the certificate using mail.domainname.com.   You will need to configure the client in the connections to direct to the Outlook Anywhere.   This is done by bringing up the Mailbox settings in Outlook.  

Let me know if you anymore questions,

Thanks,

Idea Dudes

Author

Commented:
Outlook Anywhere is installed. My problem is related to outlook on the same network as the exchange server. For some reason it sets outlook to use http by default instead of needing to manually configure this. The check box you see in the attachment was not done by me. Outlook was configured that way during auto setup.
Michael W. KroutCEO/President

Commented:
What do you have in the Exchange Proxy Settings?   This is the configuration for Outlook Anywhere.   You need to make sure that you have Outlook Anywhere configured.   Remember that you need RPC-HTTP proxy feature installed on all CAS servers.   Then you just put in the http://mail.domainname.com address in the configuration for the Exchange Proxy Setting.   Then you need to restart the transport service.   Then in your Outlook you can check the connection status by Right-Clicking the Outlook icon and selecting Connection Status.   You should see the connection being HTTPS.  

Let me know if you need more help,  

If you want to do a join.me session, I can show you what to do.  This is free of charge and should not take long at all.

Thanks,

Idea Dudes

Author

Commented:
Sorry for the delay. I dont think you understand what I am saying. Outlook Anywhere works fine when I am outside the office and I manually configure it. Outlook Anywhere is not my issue. My issue is that my local computers (on the same domain as the mail server) change themselves to use outlook anywhere internally. I dont want this to happen. The checkbox I took a screen print of is checking itself off. I dont want machines in the office, on the domain, to connect via outlook anywhere. Please let me know.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Did not have time to wait. Had to format box and do clean install.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.